Solved

sage accounts 2012 fails on backup over network

Posted on 2012-03-26
12
1,620 Views
Last Modified: 2012-06-27
hi guys,. hope you are well.

a long and complicated story.

here goes...


i have attached a network map document to help you see whats going on.

i have a customer who is an accountant. she has sage accounts 2010, 2011, 2012, accounts production and payroll installed on a laptop which we will call A.

she has been using data locally for a long time with some issues, but not many. she has now employed 2 people. i have set up a "server", which we will call B. the server is win 7 64 bit home premium, 8 gb ram, 120gb Solid state disk, dual core intel G620. it also has sage accounts software on it, accounts 2011 and 2012.

there is another pc on the network, an old win xp pro SP3 box, which we  will call C.

security is by trend micro wfbs 3.7. i have  set up all sage's suggestions for behaviour monitoring and AV, let the LAN be completely trusted bi directionally for all ports. i have then disabled behaviour monitioring and AV. i have also removed it completely, all to no avail, same issues persist.

backup is by carbonite, which is present on all 3 machines. i have scheduled this so it is paused during working hours. i have also tried removing carbonite, to no avail.

i have disabled SMB 3 and 2 on both win 7 machines, no difference.

i have set up a mapped drive to the server from the clients, turning off the "autodisconnect" parameter and applied the "persistent" flag. i dont have any issues with reading or writing to the mapped drives. the data directory on the server is in the public documents folder.
i have tried moving the data to another folder, explicitly sharing it, moving the shared data  folder to a different pc, moving the data to a sata disk on the server instead of the ssd.

i have also tried using unc paths instead of using the mapped drives.

i have set up reserved dhcp addresses on the router (a netgear wnr845t gigabit), upgraded the entire network to gigabit, set up hosts files on every machine. (see the network map for more details.). i have also tried putting A directly onto the cisco switch, and also putting the server on the netgear router, all to no difference.

the problem is that A cannot back up to the server, using sage accounts 2011 or 2012. it fails on an xml file located in one of the vat return folders. the exact file that it fails on differs, but it is always in that folder.

if you delete the contents of that folder on the server, it can back up. i have left sage to look at this. it has been nearly 2 weeks now and they dont have an answer.

the XP box (C) has never had a problem with anything, (accessing, backing up) throughout all of this, nor has the server had a problem running or backing up (although of course the sage install on the server is only doing local stuff.)

i have even built a brand new win 7 64-bit pc, completely clean, nothing on it except accounts 2012.  then i put 2011 on it as well, then it started having the same problem. i installed to a completely new folder for each install.


however, last week, my customer applied an update to the Payroll  (not accounts) software on A, which had a new pdf writer in it.

all of a sudden, accounts 2012 and 2011 work fine. everything works and has been fine for a week.

today, A has failed again, and cannot backup.

im at a complete loss - i really dont know what to do.
 
please help!
network-map.pdf
0
Comment
Question by:247computerdoctor
  • 7
  • 3
  • 2
12 Comments
 
LVL 10

Expert Comment

by:Bruce Denney
ID: 37765768
SMB 3! There is no such thing.

What did you actually do to disable SMB2 and SMB 3?

Backing up using anything other than the Sage backup routines is a recipe for failure, CHECK DATA is an essential part of backing up and is NOT done by any backup system. This does NOT check data is written to disk properly, it checkes that there are not logical inconsistencies in the data.  
see...
http://support.makingithappen.co.uk/guides/sage_50_backup_guide.htm

Is the user able to make a backup using the built in backup routines of Sage 50?

Does the user trying to do the backup really have full access rights to ALL the folders and ALL the files? An easy way to test this would be to copy the entire Sage directory from the "server workstation" to a local disk.

Is the Anti Virus configured to exclude the Sage Files/Data Folder in line with Sage Answer 12122       "Modifying your antivirus software to avoid conflicts with Sage Accounts"
0
 

Author Comment

by:247computerdoctor
ID: 37766164
hi ,

1) im using the sage backup and checking the datafile files first.
2) backup is running from client to a shared folder on the server
3) no permissions issues
4) AV configured fully. also does this with av and behaviour monitioring off, and also without entire trend WFBS client installed at all on any machine.
5) backup is by carbonite, but i have excluded the actual sage files from the backup. carbonite backs up the "sage backup" files that they run out of sage.

yeah i wasnt sure about smb3 but having gotten really desperate i followed the advice on a post somewhere -
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]
"SMB3"=dword:00000000

i guess it does nothing.

prior to that i ran the following on both client and server

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]
"SMB2"=dword:00000000


also ran on the client (PC A) from petri:

 http://www.petri.co.il/how-to-disable-smb-2-on-windows-vista-or-server-2008.htm

sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc config mrxsmb20 start= disabled


i made the mapped drive on the client as follows:

Run the fix it from   http://support.microsoft.com/kb/297684

Then

net config server /autodisconnect:-1

then

(this is to do with UAC causing problems with mapped drives) MS KB937624

"To configure the EnableLinkedConnections registry value, follow these
steps:
Click Start , type regedit in the Start Search box, and then press
ENTER.
Locate and then right-click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Sy
stem
Point to New , and then click DWORD Value .
Type EnableLinkedConnections , and then press ENTER.
Right-click EnableLinkedConnections , and then click Modify .
In the Value data box, type 1 , and then click OK .
Exit Registry Editor, and then restart the computer."

Then from dos prompt run as admin, old school way of mapping drives

net use Y: \\PCNAME\SHARENAME /persistent:yes

she still reports that the mapped drive appears disconnected in windows (red cross in mapped drive icon) even though as soon as you click on it its fine. i thought the auto disconnect reg key was supposed to sort this but it obviously hasnt.
0
 
LVL 30

Expert Comment

by:pgm554
ID: 37769305
Make sure the SSD has the latest firmware on it.

If you continue to have issues,dump the SSD and use a regular drive.

I've seen funny issues with SSD's and differing programs.

I run Sage Peachtree and it, by default,disables ipv 6,so you may want to consider that as an option too.

Consider that Win 7 64 bit may cause issues too.
0
 

Author Comment

by:247computerdoctor
ID: 37770125
Hi thanks for this.

Ipv6 is disabled already and ive tried moving the data to a sata disk all for no change...
0
 
LVL 10

Expert Comment

by:Bruce Denney
ID: 37775458
So the Sage backup isn't working, they can't create a backup file and it has nothing to do with carbonite backup.?

It always hangs on an XML file ?

My thought would be that the XML file locked open by another process/user.

Is it the same file that gets locked each time in a specific dataset?

You could monitor the file and see if another user/process has it locked.
0
 
LVL 10

Expert Comment

by:Bruce Denney
ID: 37775492
The method I have for disabling SMB2 is

Start > All Programs > Accessories > Right-click Command Prompt > Run as administrator.
sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc config mrxsmb20 start= disabled
Reboot

To monitor the file I would use Procmon
http://technet.microsoft.com/en-us/sysinternals/bb896645

Can they backup locally?
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:247computerdoctor
ID: 37776052
So the Sage backup isn't working, they can't create a backup file and it has nothing to do with carbonite backup.?

       correct

It always hangs on an XML file ?

    yup, but not a particular one

My thought would be that the XML file locked open by another process/user.

   ok, sounds good

Is it the same file that gets locked each time in a specific dataset?

    no, but it is always an xml file in a particular folder

You could monitor the file and see if another user/process has it locked.

   ok, i will give this a go. thankyou!

Can they backup locally?

   they can back up if the actual dataset is local, but they cant back up with the data set on           the server either back to the server or local.

SMB disabling is the same one i have used.

as for the ssd, i have tried moving the data to a sata disk but no difference.
0
 

Author Comment

by:247computerdoctor
ID: 37840248
this is becoming more and more bizzare. further to the above thread, i can back up sage accounts 2012 every single time with small data sets. when i get to 2 large data sets, it fails intermittently. rebooting the server allows at least one backup to be taken then it fails again. im thinking that sustained data transfer over the network is failing for some reason.

i have been looking at network issues. i have found that the name resolution on the router isnt functioning correctly every now and again. there is a machine called "debbie-vaio" (the problem laptop) but in the routers dns table, it sometimes appears as "bbie-vaio". the first 2 chars have been stripped off.

i havent had a chance to change the router, although i had the same suite of problems with another router before, which is why i changed it in the first place, although i wasnt looking for this problem with the old router so i dont know if it was doing the same thing. they are netgear routers, i know, not the best, but should be adequate for 4 clients.

something else has just come to light. the office they are situated in is part of a managed building. they have suggested we use a  vlan which i think runs off a cisco catalyst. what i thought i would do is hard code all the pc's NICs with ip addresses, dns server and gateway info , then put them on the vlan.

when i asked the guy who manages that building what the dns addresses should be, he said use open dns' servers (which i know and love).

i said but surely there must be some local dns host but he says not.

he says if i were to use DHCP off their system, i will get open dns ip addresses as the auto defined dns servers. i dont understand this - how can local names resolve if open dns is being used as the dns host? he said that they dont provide dns forwarding or hosting in the building.

he then went on to say that sometimes open dns causes problems with local dns -  which frankly doesnt surprise me if all the clients on all the vlans in his building have to use open dns as their local resolution for dns.  he then went on to explain that he has seen hosts files sort this problem - im guessing you would need hosts files if you use open dns as your primary dns server for your lan. i am already using hosts files anyway, but that was just to try and see if i could pick up the network performance. it just doesnt make any sense to me to assign open dns servers ip addresses to things inside your own lan.

im now wondering if the router that i have installed inside their network is somehow getting dns confused on its  lan side because of this. i dont know enough about dns to know - have a look at the network map if it helps. i am now severely scratching my head!

maybe this is a non starter, and im going to change the router i have anyway. i did have a plan to remove my router comletley and to use their vlan to see if this would eliminate problems but having been told this i im really not sure now!

please help!!
0
 
LVL 30

Expert Comment

by:pgm554
ID: 37840657
Have you tried mapping by IP address?
0
 

Author Comment

by:247computerdoctor
ID: 37840699
well, im using hosts files as it is. i could just try straight ip address  in the sage path to data file i suppose but im kinda keen on not doing that - need to get to the root of the problem. thanks for the suggestion - i may give it a go anyway
0
 

Accepted Solution

by:
247computerdoctor earned 0 total points
ID: 37876105
hi guys, ive given up with this and am now trying a terminal server as a solution.
0
 

Author Closing Comment

by:247computerdoctor
ID: 37896094
been advised that sage network installs in peer to peer is a disaster waiting to happen and that it would be better to use a terminal server,l so thats what im doidng!
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Storage devices are generally used to save the data or sometime transfer the data from one computer system to another system. However, sometimes user accidentally erased their important data from the Storage devices. Users have to know how data reco…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now