• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2290
  • Last Modified:

Missing utility.mda but cannot turn off the reference!

I have been given a database to migrate from Access 2000 to Access 2010.
It is sitting in a trusted location, and I get the infamous "missing or broken reference to the file utility.mda"
I can see it under References, but cannot remove the reference, as  Tools/References is greyed out.
I have had no luck finding an answer on what to do when this is the situation.
can someone please help?
I have spent several days googling to no avail.
0
Kilvroch
Asked:
Kilvroch
1 Solution
 
peter57rCommented:
The way to do this is to create a new empty database in A2010 and then use the External Data option to import everything from the existing database.

Using the 'convert' options has not proved to be very succesful in practice.
0
 
mbizupCommented:
<<Tools/References is greyed out.>>

Make sure that your code is not simply paused in 'debug' mode.

From the VBA toolbar:
Run --> Reset

(And from what I've seen, others have resolved this issue by unchecking that reference)
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
Once you remove the reference, make sure you compile the code to check for errors.  Often, developers years ago would use some of the procedures in the .MDA within their apps.  

  It may be that the reference was simply carried along from something else, or it may be that the app actually used a procedure in the lib which you'll need to deal with if that's the case.

Jim.
0
Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

 
KilvrochAuthor Commented:
I'm trying to import the old database into a new one, and get :

you do not have the necessary permissions to use the 'olddatabase.mdb' object. Have your system administrator or the person who created the object establish the appropriate permissions for you.

I am an Admin on the computer where I am trying to install this database.
0
 
KilvrochAuthor Commented:
Update: a colleague has helped me with this - he is still on WinXP and Office 2003. He was able to turn off the reference in his copy of the database, and give me a .mda file to go along with it.

I created a shortcut on my Win7 Office 2010 machine, to open the database with /wrkgrp pointing to the .mda file, and can now open the database.

What an annoying and frustrating thing. One of my goals is to convert this thing to SQL Server and get rid of that stupid Access User / Workgroup stuff

thanks
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
<<I created a shortcut on my Win7 Office 2010 machine, to open the database with /wrkgrp pointing to the .mda file, and can now open the database.>>

 Your mixing apples and oranges here; utility.MDA was a library of code used by Microsoft in conjunction with Access.   It is not a security work group file.

 You should not be pointing to utility.MDA with the /wrkgrp switch.  If you do, your going to have problems.

Jim.
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
oops, missed your comment prior to your last.

Jim.
0
 
KilvrochAuthor Commented:
that's okay, Jim.... we still haven't solved the core problem, just found a work-around. We've got many more databases to convert and I'm sure we need a 'real' solution to when it is not possible to change the references in an old database.
0
 
KilvrochAuthor Commented:
I gave up and used a work around
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now