Dell Vostro 1700 power issue

Posted on 2012-03-26
Medium Priority
Last Modified: 2016-11-23
Will not operate away from ac power. Have replaced ac charger and battery with known good units. Anything else to try before replacing the motherboard?
Question by:MapleLife
LVL 16

Assisted Solution

by:R. Andrew Koffron
R. Andrew Koffron earned 1000 total points
ID: 37765818
update bios and call dell, even if it's out of warranty they'll usually try and help a little like telling you if there is a rest command or stuff like that, don't expect a big long help session on an expired machine but it's worth a shot.
LVL 93

Accepted Solution

nobus earned 1000 total points
ID: 37770239
what happened when you put in a good battery?
did it show the battery, and the charge - and did it charge?
if not, it looks like the charging circuits on the mobo are bad -  and , as you supposed, the mobo should be replaced

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

On Beyond Tools A conversation I recently had with the DevOps manager of a major online retailer really made me think about DevOps monitoring tools (https://www.onpage.com/devops-incident-management-tool/). The manager and I discussed how sever…
This applies to Dell but may also apply to other manufacturers as well. We ran across a few machines that just dropped recently it trust relationship with the server. After doing the basic removing and joining the domain again, it changed to No logo…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
How to fix display issue, screen flickering issue when I plug in power cord to the machine. Before I start explaining the solution lets check out once the issue how it looks like after I connect the power cord. most of you also have faced this…

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question