Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Issues Changing Cisco Port to Switchport

Posted on 2012-03-26
5
Medium Priority
?
3,845 Views
Last Modified: 2012-04-11
Hello Experts,

When I paste the following config (see at end of discussion) I keep on getting the error message 'Command rejected: Not a switchable port'

interface Port-channel2

 switchport

 switchport trunk encapsulation dot1q

 switchport mode trunk

 no shutdown

Router(config)#interface Port-channel2

Router(config-if)# switchport

Command rejected: Not a switchable port.

Then when I enter configure the actual interface I get the following error:

Router(config-if)#int eth 1/1

Router(config-if)#interface Ethernet1/1

Router(config-if)# switchport

Router(config-if)# switchport trunk encapsulation dot1q

Router(config-if)# switchport mode trunk

Router(config-if)# duplex auto

 

Router(config-if)# channel-group 2 mode passive

Command rejected (Et1/1): Either port is L2 and port-channel is L3, or vice-versa

Now, this occurs only when I paste the entire config as follows:

!

hostname ALS1

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

ip cef

!

no ipv6 cef

!

!

!

spanning-tree mode mst

spanning-tree extend system-id

spanning-tree pathcost method long

!

spanning-tree mst configuration

 instance 1 vlan 100, 200

 instance 2 vlan 300, 400

 instance 3 vlan 500, 600

 instance 4 vlan 700, 800

!

spanning-tree mst 3 priority 0

errdisable recovery cause channel-misconfig

errdisable recovery interval 600

!

vlan internal allocation policy ascending

!

!

!

!

!

!

!

interface Port-channel2

 switchport

 switchport trunk encapsulation dot1q

 switchport mode trunk

 no shutdown

!

interface Port-channel4

 switchport

 switchport trunk encapsulation dot1q

 switchport mode trunk

 no shutdown

!

interface Ethernet0/0

 no ip address

 shutdown

 duplex auto

!

interface Ethernet0/1

 no ip address

 shutdown

 duplex auto

!

interface Ethernet0/2

 no ip address

 shutdown

 duplex auto

!

interface Ethernet0/3

 no ip address

 shutdown

 duplex auto

!

interface Ethernet1/0

 switchport

 switchport trunk encapsulation dot1q

 switchport mode trunk

 duplex auto

 channel-group 2 mode passive

 no shut

!

interface Ethernet1/1

 switchport

 switchport trunk encapsulation dot1q

 switchport mode trunk

 duplex auto

 channel-group 2 mode passive

 no shut

!

interface Ethernet1/2

 switchport

 switchport trunk encapsulation dot1q

 switchport mode trunk

 duplex auto

 channel-group 4 mode passive

 no shut

 

interface Ethernet1/3

 switchport

 switchport trunk encapsulation dot1q

 switchport mode trunk

 duplex auto

 channel-group 4 mode passive

 no shut

interface Ethernet2/0

 no ip address

 shutdown

 duplex auto

!

interface Ethernet2/1

 no ip address

 shutdown

 duplex auto

!

interface Ethernet2/2

 no ip address

 shutdown

 duplex auto

!

interface Ethernet2/3

 no ip address

 shutdown

 duplex auto

!

interface Ethernet3/0

 no ip address

 shutdown

 duplex auto

!

interface Ethernet3/1

 no ip address

 shutdown

 duplex auto

!

interface Ethernet3/2

 no ip address

 shutdown

 duplex auto

!

interface Ethernet3/3

 no ip address

 shutdown

 duplex auto

!

interface Vlan1

 no ip address

 shutdown

!

!

no ip http server

!

!

!

!

!

control-plane

!

!

line con 0

 logging synchronous

line aux 0

line vty 0 4

 login

 transport input all

!

end

 

ALS1#

I should mention that the configs work fine when I built them from scratch. I only have problems when pasting the whole configs in one shot.

My guess is that switch doesn't like the port-channels to be pasted in before the actual configs for the actual interface - but thats just a wild guess.

Can you please shed some light on the situation?

Cheers

Carlton
0
Comment
Question by:cpatte7372
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 29

Expert Comment

by:Jan Springer
ID: 37766444
Configure the trunking on the physical interfaces and put those interfaces into the port-channel group.
0
 

Author Comment

by:cpatte7372
ID: 37766593
jesper,

I think the problem was the fact that when pasting the configs I was pasting the configs for the logical interfaces before the configs for the actual interfaces
0
 
LVL 29

Expert Comment

by:Jan Springer
ID: 37766650
sure but you still don't need to define that information within the logical interface.
0
 
LVL 15

Accepted Solution

by:
Nayyar HH (CCIE RS) earned 2000 total points
ID: 37770643
The command "channel-group 4 mode passive" creates the logical interface

After which the logical interface would inherit relevant configurations from the physical interfaces.

Onwards Going forward logical/topology changes are made to the logical interface.
0
 

Author Closing Comment

by:cpatte7372
ID: 37832268
Cheers
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
Arrow Electronics was searching for a KVM  (Keyboard/Video/Mouse) switch that could display on one single monitor the current status of all units being tested on the rack.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question