Windows XP Mode - WLAN Issue

Hi there,

I'm strugelling to add my WLAN adapter to the Windows XP Mode Virtual Machine.

My host machine is a Dell Latitude running Win7 64-bit.  The WLAN adapter is an Intel Centrino Advanced-N 6205 which has the latest drivers installed.

Within XPVM settings I've added 2 adapters:

1 - Shared Networking (NAT)
2 - Intel Centrino Advanced-N 6205

Integration Features are set to Auto-Enable.

When I start the VM I get 2 physical connections within 'network connections' and if I look in Device Manager I have 2 of the following network adapters:

Intel 21140-Based PCI Fast Ethernet Adapter (Generic)

Within the host system I've even disabled the Virtual PC Network Filter Driver on the physical adapter and have enabled it on the WLAN adapter but it still doesn't work.

Any ideas?

Cheers, Andy
andrewprouseAsked:
Who is Participating?
 
rindiCommented:
This is normal in XP mode, it shows you the virtual adapter which the VM's Virtual Hardware provides you with, and that is the "Intel 21140-Based PCI Fast Ethernet Adapter (Generic)". This Virtual adapter then attaches to one or the other of your system's actual Adapter, whether that is a wireless or Ethernet adapter.

If for some reason you really need to see a WLAN adapter as a WLAN adapter within XP mode, you will have to use a USB WLAN adapter. Then you can use the Virtual PC Menu in XP mode with the "USB" option, select "Wireless/Bluetooth Device", and then "Attach". This will disable the device within Windows 7 itself and make it available inside XP mode exclusively, where you can then install it's drivers so it gets usable.
0
 
andrewprouseAuthor Commented:
Thank you.  I do need it to appear within XP Mode as a WLAN adapter so I'll purchase a USB WLAN adapter and follow your instructions.

Many thanks, Andy
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.