Solved

cannot telnet to mail server on port 25

Posted on 2012-03-26
8
710 Views
Last Modified: 2012-03-27
Hello Folks,

I have a mail server using just the IIS 6.0 SMTP relay. I am trying to mass mail to my customers on comcast, and my mail is not leaving the outgoing queue on it. I have disabled my antivirus. I cannot telnet to mx1.comcast.net on port 25, BUT I can telnet to its IP address. This is not the case with other mail servers like yahoo's. I am not having this trouble on my laptop as I can telnet to mx1.comcast.net and mx2.comcast.net. But I can only use those IPs to telnet to on the SMTP server. Is this possibly keeping this mail in the outgoing queue? I have tried rebooting and restarting the SMTP service. It is an update 2003 Windows server. Thanks!
0
Comment
Question by:mrosier
8 Comments
 
LVL 7

Expert Comment

by:Ilya Rubinshteyn
ID: 37767216
It may be using secured SMTP for outbound transfer, I believe the port is 465? check the settings for comcast mail transfer on their site. You also need to have an authentication mechanism for the site.
0
 

Author Comment

by:mrosier
ID: 37767239
Well I was sending ok over the weekend without issue, and I actually have clear status on my connection sending the mail. They have confirmed to me that I should have a clear path to deliver my mails to comcast.net users. I have authentication requirements on my SMTP service on that server as well. What I don't understand is why I can telnet to port 25 of the IP addresses of those two servers but not the regular canoical names of those two servers? Could that be stopping me somehow?
0
 
LVL 7

Accepted Solution

by:
Ilya Rubinshteyn earned 500 total points
ID: 37767264
Oh, i did not realize you can telnet to the IP but not the FQDN. what happens when you ping the FQDN? try adding a manual entry pointing the fqdn of the server to the IP address and flushing the DNS settings on the machine.
0
 

Author Comment

by:mrosier
ID: 37767305
DNS did the trick! my primary DNS server under the TCP/IP settings was out of date, and I forgot to update it as I have that machine's TCP/IP settings manually configured as it is a mail server. I changed it to the current DNS primary, was able to make the telnet sessions go with the FQDNs, flushed DNS, restarted the SMTP service, and mail started flowing. Thanks so much!
0
Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

 

Expert Comment

by:ExchangeOnTheRocks
ID: 37767315
From the IIS box, type nslookup and try to resolve the MX records of comcast.net. Are you able to see all the details successfully?
Secondly, on the properties of the SMTP virtual server, do you have any DNS server specified under Advanced settings?
0
 
LVL 38

Expert Comment

by:Adam Brown
ID: 37767546
It may be using secured SMTP for outbound transfer, I believe the port is 465?

As a note, Secured SMTP does not use a different port by default. Secure SMTP uses the STARTTLS command in SMTP to initiate a TLS secured SMTP communication. You can assign a different port for Secure SMTP from client to server (Like Google does, primarily to bypass ISPs that block SMTP for residential users), but most secure SMTP for server-to-server still goes over port 25.
0
 
LVL 17

Expert Comment

by:Gaurav Singh
ID: 37770535
please check with your provide if the SMTP ports are opened from their end, its likely b the issue with port blocking
0
 

Author Closing Comment

by:mrosier
ID: 37771205
The DNS check reminder showed me I had an out of date DNS server on the TCP/IP settings of that network connection. Thanks!
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now