Solved

full duplex

Posted on 2012-03-26
16
515 Views
Last Modified: 2012-04-20
I have a PC with a Gig NIC card connected to a gig port of a Cisco 3560. When I hard coded full duplex and speed 1000, the connection went down. When I set it up for Auto, ut came up as 100mbps. I want to get a gig link between the switch port and the PC. But it does not seem to work. Thanks
0
Comment
Question by:biggynet
  • 4
  • 3
  • 2
  • +6
16 Comments
 
LVL 95

Expert Comment

by:Lee W, MVP
ID: 37769524
I've most often seen this behavior when you have a Category 5 cable somewhere in between the PC and the switch - Gigabit - reliable gigabit - requires Category 5e or 6.
0
 
LVL 5

Expert Comment

by:atechnicnate
ID: 37769529
I'd double check that you have a cable that is rated for it and also make sure your NIC isn't hard coded to 10/100 auto.  Perhaps it dropped because of the NIC card.  An easy way to test this is to enable spanning tree to prevent a switch loop and then connect the cable from one switch port into another port on the same switch and it should allow for full duplex 1000 speed. (I think this should work but I don't have a switch on hand to test it with)
0
 
LVL 5

Expert Comment

by:abhishek1986
ID: 37769595
Go to properties of the NIC and check if it is set for 1000 Mbps duplex?
If it is set to auto duplex, it should take 1 Gbps speed automatically, but you can try and give it 1000Mbps duplex and check. In any case there won't be Network cable disconnect message on display.
Also, theoretically, you will need a cat 5e or higher version of a cable for 1 Gbps speed. Also I am guessing that you have your pc connected directly to 3560 without any other network connection between them.
0
 

Author Comment

by:biggynet
ID: 37769642
yes PC directly connected to the switch port.
0
 
LVL 95

Expert Comment

by:Lee W, MVP
ID: 37769661
... and the cable is category ...????
0
 
LVL 5

Expert Comment

by:abhishek1986
ID: 37769726
The category of the cable will be mentioned on the cable. Check to see it. Also, you can force your NIC to take 1000 Mbps duplex connection. Go to Properties of the card and configure it.
There, in advanced tab, you will find option to set Link speed. Just change it and do the same on the switch too.
0
 

Expert Comment

by:Matrex_a2003
ID: 37770314
use cross cable
0
 

Author Comment

by:biggynet
ID: 37770703
cross cable? between the PC and the switch?
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 5

Expert Comment

by:shubhanshu_jaiswal
ID: 37771000
when you hardcoded the link and connected the system what was the output of below command

sh ip int brief
0
 

Accepted Solution

by:
Toluene earned 250 total points
ID: 37771226
You can only use a crossover cable if it's a smart switch.  I have seen two Gig cisco switches only talk at 100.  Turned out to be a config error in one of the switches.  Have you tried to connect a different device to the switch to make sure that it can connect at 1000?  If that works, then try adding your cabling to the equation and see if that works.  If all of that works at 1000, then the problem is your NIC or a setting and not the switch.
0
 
LVL 95

Expert Comment

by:Lee W, MVP
ID: 37771479
IS THE CABLE YOU ARE USING A CATEGORY 5E OR CATEGORY 6 CABLE?
0
 

Author Comment

by:biggynet
ID: 37771663
looking into it. Have to be on site.
0
 
LVL 2

Expert Comment

by:BDC-Net
ID: 37772054
How far is the cable run? If it isn't far a cat5e will run gig. Even if the specs don't suggest it. There may be a bad pin in the cable. To run gig over ethernet it requires the use of more pins than to run 100mb. I have seen cases where there was a bad pin that wouldn't let the computer connect at gig but it would at 100mb. Also, best practice is to use auto if you are connecting at gig.
0
 

Author Comment

by:biggynet
ID: 37828582
"best practice is to use auto if you are connecting at gig." I just want to confirm that this is true. I thought that best practice is to hard code the speed. Thx
0
 
LVL 2

Expert Comment

by:BDC-Net
ID: 37828619
If you are connecting at a gig then use auto... if you are using a connection with a gig switch to a 100mb devices we have seen issues (sometimes) with using auto. Sometimes it will go to half duplex. When it comes to a full gig connection we have seen way more issue trying to force the connected instead of doing auto.
0
 
LVL 4

Assisted Solution

by:jader31
jader31 earned 250 total points
ID: 37838322
Try to start with a 1000 Half duplex... try on to verify if it works. Define it manually in both sides (switch and NIC).

If possible, try to put computer VERY CLOSE to switch and use a known working cable.

Later, if you still have problem, change port on switch to a known working at gigabit speed port.

And as final and desperate measure, try to replace OS of computer (use a linux distro in CD/DVD it's easier/quicker way to test it)... maybe your OS isn't understanding something and do not accept to work at Giga speed.

Good luck.
Jáder
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Join & Write a Comment

In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now