Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 231
  • Last Modified:

apache question

We have a VPS server and one drupal site hosted on it.

There is some issue with regards to the Apache configuration, the website runs out of memory and shows fatal error sometimes.

The hosting people have replied below:




--------Switch to worker or event and use the "ulimit -s 128" (add the ulimit line at the beginning of the apache init script: /etc/init.d/httpd after you switch to event or worker)------



Can someone explain how to do this please?
0
DantechIT
Asked:
DantechIT
1 Solution
 
stephencolsonCommented:
Is the error that PHP is running out of memory? This can be a common error for Drupal sites, and it isn't an Apache problem. Likely, you need to increase the memory_limit variable of your php.ini. Can you tell me what this variable is currently set to?
0
 
babuno5Commented:
here is more info about why you should switch to worker model of apache and php

http://brian.moonspot.net/2008/02/13/apache-worker-and-php/
http://www.php.net/manual/en/faq.installation.php#faq.installation.apache2

You will need to recompile apache and php to enable the same
0
 
LinuxGuruLinux Server AdministratorCommented:
Whats the exact error message? If you are facing out of memory error you need to increase the memory limit in your server php.ini.

You can use the following command to locate php.ini

php -i | grep php.ini

Open in new window


Above will output the loaded php.ini file. Now edit the php.ini and increase the value of memory_limit.

memory_limit = 128M

Open in new window

0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now