Solved

Disable Base64 Encoding for Specific Mailbox/Contact on Exchange 2010

Posted on 2012-03-26
4
4,515 Views
Last Modified: 2012-04-02
Hi Guys,

Is there a way to Disable Base64 Encoding for a Specific Mailbox/Contact on Exchange 2010?

We're having issues with our Managed Services Software whereby we've narrowed it down so that emails sent from the application are being encoded in Base64 and our SMS Provider that receives these emails doesn't support it - Simply SMS's us as Base64 messages.

Thanks in Advance!

Cheers,
Ray.
0
Comment
Question by:UncleRaymondo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 15

Expert Comment

by:tenaj-207
ID: 37772732
It appears that you can only change the encoding for the Exchange server as a whole, not on individuale mailboxes.  

Here's more information;
http://technet.microsoft.com/en-us/library/gg144562.aspx
or
http://technet.microsoft.com/en-us/library/bb310794.aspx
0
 
LVL 27

Expert Comment

by:tliotta
ID: 37774354
Be aware that if base64 encoding (or similar encoding) is needed because the e-mail contains anything but 7-bit ASCII text, then you're trying send stuff that is not allowed without encoding. That's just a fundamental requirement.

Tom
0
 

Accepted Solution

by:
UncleRaymondo earned 0 total points
ID: 37776483
Hi Guys,

Thanks for the replies, but I've managed to resolve the issue about 5 minutes ago. Tom, that's true, but for some reason, this SMS provider (of which the Email Alerts get forwarded to), doesn't support Base64 Encoded Emails/Messages and the Base64 Encoded message is what was appearing in the SMS Messages.

Tenaj-207, you can actually be a lot more specific than the whole Exchange Server. How I fixed it was by creating a New-TransportRule, changing the Content-Type header from text/html to text/plain and then removing the Content-Transfer-Encoding header which is where it said base64. The actual command is as follows:

New-TransportRule -Name '<call it whatever here>' -Comments '' -Priority '0' -Enabled $true -SentTo '<put the external email you're sending to here>' -SetHeaderName 'Content-Type' -SetHeaderValue 'text/plain' -RemoveHeader 'Content-Transfer-Encoding'

Once we did that, the email alerts via our SMS provider to our phones came through as readable text :)

Thanks again for your help!

Cheers,
Ray.
0
 

Author Closing Comment

by:UncleRaymondo
ID: 37795068
Issue Self Resolved
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
The recent Petya-like ransomware attack served a big blow to hundreds of banks, corporations and government offices The Acronis blog takes a closer look at this damaging worm to see what’s behind it – and offers up tips on how you can safeguard your…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question