Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1025
  • Last Modified:

Cisco 2960 Issues

Experts,

I have a Cisco 2960 connected to a Cisco 3560 ( core switch ), the other day the link went down for no apparent reason and will not come back up. I've tired the following on the 2960:
Shut / no shut on the port
Set default on settings for G0/1
Re enabled the configs for G0/1
Reboot switch
Checked other switch configs and verified settings were the same
Used a different working cable, same issue ( no link lights )

I've plugged in a unmanaged 20$ switch to the link coming from the core switch and it greens up.... Weird?

I checked the settings on the core switch for that link:
Set default on all configs for that port
Did a shut/no shut
Re enabled the settings on port
Checked other port settings for other switches on core and verified settings were correct
I don't want to reboot core switch as it will knock out everyone else unless I have to

Core switch settings:
Fa0/38
Switchport mode trunk
Switchport trunk encapsulation dot1q

Cisco 2960 settings:
G0/1
Switchport mode trunk

Thanks
0
MattLight
Asked:
MattLight
  • 6
  • 3
  • 2
  • +2
3 Solutions
 
PaulNSWCommented:
are the ports showing as err-disabled?

what are the outputs of
show interface fa0/28 status
and
show interface gi0/1 status

is there a reason why you have encapsulation defined on only the core port?
0
 
abhishek1986Commented:
Is only that port causing problems?
Have you tried it in other ports?
Give the output of
Switch# show interface f 0/28            {for 2960 switch}
and
Switch# show interface g 0/1              {for 3560 switch}
0
 
usslindstromCommented:
The 2960 probably only allows for Dot1q anyway.


But - I'd force the speed and duplex, instead of letting it auto-detect here.

int fa0/28
speed 100
duplex full

int gi0/1
speed 100
duplex full
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
MattLightAuthor Commented:
I tried a diffrent port and set the same settings on fa0/4, still same issue.

here is the show run on fa0/4 ( 3560 core ):

MWRCore#show int fa0/4
FastEthernet0/4 is down, line protocol is down (notconnect)
  Hardware is Fast Ethernet, address is 44e4.d967.a806 (bia 44e4.d967.a806)
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 76843 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     371 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 9 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

2960 G0/1 :

Adminsw#show int g0/1
GigabitEthernet0/1 is down, line protocol is down (notconnect)
  Hardware is Gigabit Ethernet, address is 64a0.e748.cbb1 (bia 64a0.e748.cbb1)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Auto-duplex, Auto-speed, link type is auto, media type is Not Present
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 01:38:39, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     2 packets output, 128 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

@PaulNSW - i cannot set the encapsulation on the 2960, it doesnt give me the option

@usslindstrom - i will try that here in a minute and update you guys with the results
0
 
abhishek1986Commented:
Are the two switches directly connected?
Please check the cable and if possible change it to be sure.
And why have you displayed the result of f 0/4 for the core switch?
0
 
MattLightAuthor Commented:
ok, was able to set the speed to 100 and duplex full on the 3560 but not on the 2960 for some reason.
0
 
MattLightAuthor Commented:
i have a working Cat5e to the Core Switch (3560) as the cheap unmanaged switch works flawlessly. i listed fa0/4 because i tried a diffrent port on the switch troubleshooting. (see above posts ). fa0/4 is now the current port where the 2960 is now plugged in at.
0
 
usslindstromCommented:
try to preface the command with

int g0/1
media-type rj45
speed 100
duplex full
0
 
MattLightAuthor Commented:
the preface command worked, however im doing some more troubleshooting here, i set the port on the core switch (3560) to all default, then just enabled switchport mode access and spanning-tree port fast - this should allow me to just plug in a laptop. i should see link lights on the laptop yet not getting any..... i plug it back into the unmanaged switch..... bam link lights... i think something funny is going on here. give me about 20 min to reboot the core switch and then bring the 2960 over to the core switch to test.

Ill be back on in a few. yay!
0
 
Matrex_a2003Commented:
use cross cable ..
0
 
usslindstromCommented:
If you've manually defined the port settings, and still not getting connections - the next step I'd check is what PaulNSW mentioned - and check to see if the ports in err-disabled state.

On the same track, then - checking to see if Spanning Tree has dumped the port into blocking as well (but forcing it as portfast like you did would rule this out).

Keep in mind that swapping between different devices, you'd need to be swapping your cable out as well.  Like devices need a crossover.
    Switch-Switch = Crossover
    Switch-PC = Straight Through

The little unmanaged switch might have an auto X-over link built into it.
0
 
MattLightAuthor Commented:
ok, so i bring the switch over to the core switch, grab a patch cord ( straight through ) and hook in... green lights!

this is what i really dont understand though,

out of two good cat5e cables that work in an unmanaged switch ( cables are terminated straight through ) dont work on the cisco switch or a laptop.

looks like i will be busy pulling cable.
0
 
MattLightAuthor Commented:
everyone posted comments quickly to help resolve this issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now