[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Sharepoint Document Review library folder issue

Posted on 2012-03-27
3
Medium Priority
?
406 Views
Last Modified: 2012-03-29
Hello All,

I have a Sharepoint site for intranet usage.
I have created a Document Review library based in on of the great templates Microsoft released for wss3.0.
My Library name is: InternalDocuments
Inside of this library I have 3 folders: "Approved", "Drafts" and "Obsolete".

My "Approved" folder is to keeo the approved documents that can be used with no issue.
My "Drafts" folder is for documents that are not yet approved, some kind of work in progress.
My "obsolete" is for archived documents, documents we don't use anymore.

I have some workflow to manage this library but there is one think I would love to do by workflow and I am not able to.

I would like to create a workflow that moves a document from the "Drafts" folder to the "Approved" folder when the document status changes from "draft" to "approved".

It's very easy to move items between lists if you use the "Copy List item" function in the workflow...I can even use the "creat list item". But the problem is to add the path to the specific folder I want.

Can someone give a little help on this?
0
Comment
Question by:stawse
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 11

Accepted Solution

by:
svetaye earned 2000 total points
ID: 37770759
Hello,
I think your only option is to use custom SharePoint designer Activity:
http://spdactivities.codeplex.com/wikipage?title=Copy%20List%20Item%20Extended%20Activity
0
 

Author Comment

by:stawse
ID: 37781192
It's an interesting tool and I have tested it but nothing happens. When I select one of the action the tool offers, nothing happens. Any suggestion?
0
 

Author Comment

by:stawse
ID: 37781962
Well, it seems it takes some time for this to work perfectly!

I just had to wait a couple of hours, give it another try and it was working....

It's great, it works just fine for me! It definetly does the work!

Thanks a lot for your help!

Regards!
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Pimping Sharepoint 2007 without Server-Side Code Part 1 One of my biggest frustrations with Sharepoint 2007 in the corporate world is that while good-intentioned managers lock down the more interesting capabilities of Sharepoint programming in…
SharePoint Designer 2010 has tools and commands to do everything that can be done with web parts in the browser, and then some – except uploading a web part straight into a page that is edited in SPD. So, can it be done? Scenario For a recent pr…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question