WAN printing via RDP

We have a 32 bit Windows 2008 Server (SP2) running Terminal Services and hosting an application.  Remote users can connect and run the application without problem.  The remote users can print to an HP network printer on their local LAN ( without problem from their Windows 7 PC and they can print to printers on the remote network ( using their terminal services connection.  They CANNOT print back to their local network printer from the terminal services session using either the redirected printer or a printer setup on the terminal server.  

Terminal server IP is -- can ping remote printer at but cannot print to it from the Windows printer.

Remote user PC (W7) can ping printer at and printer at

Two locations are connected by a Sonicwall VPN and all ports are explicitly open through the VPN.  

The printer we are trying to print to is an HP P2035N using a PCL5 driver.  

Any ideas?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Robert Sutton JrSenior Network ManagerCommented:
Make sure the "Local Resources" is enabled in the RDP Options ?
1 - The HP P2035N has to be defined, exist, in the workstations printer configuration.
2 - In the RDP Options of the workstation, make sure that under the Local Resources the Printers box is checked.
3 - Each persons AD profile on the WinServer 2008 must have under Environment the two boxes checked for Connect to client printer at logon and Default to main client printer.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SolarWinds® Network Configuration Manager (NCM)

SolarWinds® Network Configuration Manager brings structure and peace of mind to configuration management. Bulk config deployment, automatic backups, change detection, vulnerability assessments, and config change templates reduce the time needed for repetitive tasks.

synetronAuthor Commented:
Perhaps I was not clear.  We are not trying to use a terminal services printer redirection (though I mentioned that that also does not work).  We are trying to print from a W2008 terminal server to a remote network printer.  Does not work regardless of whether or not in a terminal session.  Meaning I cannot sit at the console of the W2008 and print to that printer.  But a user on that remote LAN can print to that printer.  All ports are open on the VPN.  

The printer driver is installed on the W2008 server (using the correct IP port), and on the PC which connects via RDP.  

I also cannot browse to the printer interface from the server although I can from the remote workstation.  I can ping it from both locations.

The cited AD values are already checked as are the RDP connection options.
Try removing the printer from the WinServer 2008 on your network. Make sure you are VPN connected to the other network. Again do an add printer. Add printer as a Network Printer. The browse should see the printer.
synetronAuthor Commented:
It finds the IP (after some delay), and asks for driver, which I provide, and installs without error.  Never prints the test page.  Settings are identical to the Windows printer I deleted.
Maybe you could try a basic printer driver like LaserJet 4P, with less overhead.
This only on the server side.
synetronAuthor Commented:
Tried 4P but didn't expect much since it didn't support network printing.  But also tried 4Plus which does support network printing and no luck there either.  

I tried telnet  9100 without success - times out.  When I do that on a local network printer it prints whatever I type from the telnet prompt (after aborting the telnet session).  

We have power cycled the printer just in case.
Need to look at the routers. I'll get back to you.
synetronAuthor Commented:
Both routers are Sonicwall TZ100 with latest firmware.  VPN is up and all ports LAN/VPN and VPN/LAN open on both sides.  Certainly could be a problem there somewhere but not on the surface.  We are printing through another Sonicwall VPN with no difficulty.
synetronAuthor Commented:
Problem required multiple resolution steps.  Printer had inherited a gateway from an earlier network config -- changed that to current gateway (primary resolution of problem).  User was connecting RDP session through public IP while printer was accessible only through VPN.  RDP client printers were named similar to the server based printer causing confusion.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Internet Protocols

From novice to tech pro — start learning today.