Solved

HELP!!!  Having some issues with SharePoint Foundation after implementing SSL self-signed cert to it.

Posted on 2012-03-27
10
318 Views
Last Modified: 2012-05-14
I am using a SharePoint Foundation 2010 test server to test the process of implementing SSL on Foundation.  I have performed the following steps according to these two articles.  I diverged a little by using a self-signed cert and using Internal URL rather than a Public URL.


http://www.sharepointconfig.com/2010/03/configuring-a-sharepoint-website-to-allow-ssl-connections/


http://blogs.msdn.com/b/sowmyancs/archive/2010/02/12/how-to-enable-ssl-on-a-sharepoint-web-application.aspx


So, not sure why, but anyone can view the SharePoint site now, which before I implemented SSL only those who had permissions in the Permissions Level list could.  They would be required to authenticate to even view the site.

Not sure what changed, but before I proceed further with the actual third-party SSL cert install on my production SharePoint Foundation server, I need to figure this out so it doesn't occur on it.

Server: Server 2008 R2, SQL 2005 x64 SP4, SharePoint Foundation 2010

Any ideas or suggestions to check/verify?

Thanks in advance.
0
Comment
Question by:rsnellman
  • 5
  • 3
  • 2
10 Comments
 
LVL 38

Expert Comment

by:Justin Smith
ID: 37776488
In Central Admin - APplication Management - Web App Management, select your web application and up in the ribbon, click User Policy.  Take a  screen shot of this box and post here.
0
 

Author Comment

by:rsnellman
ID: 37782217
OK, here is the screenshot.

This is the User Policy for "SharePoint - 80" web application.  Using URL "http://servername/"

Say does this issue have anything to do with the unconfigured Alternate Access Mappings?
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 37782238
I dont see the screen.  I thought you said you had already configured your AAM???  Can you post a screen of that too?
0
 

Author Comment

by:rsnellman
ID: 37782253
I was having issues, so I believe I removed those settings.

Hmmmm...OK.  Let me reconfigure that and then retake screenshots for you.
0
 

Author Comment

by:rsnellman
ID: 37782397
OK. Let me see if these attachments actually attach.
SharePoint-01.jpg
SharePoint-02.JPG
0
Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

 

Author Comment

by:rsnellman
ID: 37782402
You will notice the account it is logged in as System Account.
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 37782750
Unless you are using a proxy, you should have your Public URL match your Internal.  I don't think that would would cause your site to be open to everyone though.  Very strange.
0
 

Author Comment

by:rsnellman
ID: 37783496
How do you configure the Internal & Public URLs to match?
0
 
LVL 5

Accepted Solution

by:
dmoghe earned 500 total points
ID: 37836116
Looks like the issue is with AAM, how do you want the end user to browse the site? using https  or http?

If http, then the current settings are good. If you want them to use https, then following should be the entry.

https://janustestsrvr             Default    https://janustestsrvr
http://janustestsrvr               Default    https://janustestsrvr
http://janustestsrvr:24907    Intranet  http://janustestsrvr:24907

For this you will click on 'Edit Public URL' and first remove all the entries. Later go ahead & add https://janustestsrvr  in the Default zone and http://janustestsrvr:24907 in the Intranet zone.

Click Ok and you would see the AAM as :
https://janustestsrvr             Default    https://janustestsrvr
http://janustestsrvr:24907    Intranet  http://janustestsrvr:24907

Now click on 'Add Internal URL' and add http://janustestsrvr  & select 'Default' zone and click Ok. You should get the above result.

Hope this helps!
0
 
LVL 5

Assisted Solution

by:dmoghe
dmoghe earned 500 total points
ID: 37836122
But if you want users to access both http & https, then your AAM should look like this :

http://janustestsrvr                 Default    http://janustestsrvr
https://janustestsrvr               Intranet   https://janustestsrvr
http://janustestsrvr:24907     Internet   http://janustestsrvr:24907
0

Featured Post

Do email signature updates give you a headache?

Constantly trying to correctly format email signatures? Spending all of your time at every user’s desk to make updates? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Roaming Profiles 8 60
Sophos Enterprise migration to Cloud? 2 17
shadow copies 7 16
DNS Scavenging configuration 5 19
Scenario:  You do full backups to a internal hard drive in either product (SBS or Server 2008).  All goes well for a very long time.  One day, backups begin to fail with a message that the disk is full.  Your disk contains many, many more backups th…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now