Solved

Default VLAN untagged Procurve HP

Posted on 2012-03-27
23
950 Views
Last Modified: 2012-04-18
Hello,

I have 3 running networks on a HP Procurve Switch 2 privates (172.16.1.0/24 and 192.168.0.0/16) and a public network. I don't loose traffic on pvt 172.16 and also on public. On the 192.168 I keep loosing packets and btw this is separated by default vlan (untagged) this could be the problem?
0
Comment
Question by:goncalogirao
  • 11
  • 8
  • 4
23 Comments
 
LVL 6

Expert Comment

by:RKinsp
ID: 37774643
Hello, the untagged vlan separation should not be a problem. You are loosing packets from where to where? Can you send your config and version?

If you are routing between vlans, make sure you have ip routing enable. I've seen procurve's route some packets but not all when routing is disabled.

-RK
0
 

Author Comment

by:goncalogirao
ID: 37775518
I'm loosing packets between my ISP's Router and fibre optics equipment. This is very strange, on my local network (i ping the gateway->ips's router and don't loose anything), but if I ping a public address (the one on the public side of the router I keep loosing.

What config do you need, the Switch?
  Port   DEFAULT_VLAN   VLAN-pbWY    VLAN-pvtL4S
  ---- + ------------  ------------  ------------
  11   | Untagged      No            No    
  12   | Untagged      No            No    
  13   | Untagged      No            No
  14   | Untagged      No            No
  15   | Untagged      No            No
  16   | Untagged      No            No
  17   | Untagged      No            No
  18   | Untagged      No            No
  19   | Untagged      No            No
  20   | Untagged      No            No
  21   | Untagged      No            No
  22   | Untagged      Tagged        Tagged

 Actions->   Cancel     Edit     Save     Help
0
 
LVL 6

Expert Comment

by:RKinsp
ID: 37776830
It sounds more like your router does not have routes to all your internal VLANs. When you say you loose pings, is it like if you ping from VLAN X you loose all pings or you loose one or two pings and three make it through?

Does your ISP router have firewall active? Can you send a diagram of your network showing which pings you are loosing and which ones you are not?

A stateful firewall could block some packets but not all depending on the connection.
0
 

Author Comment

by:goncalogirao
ID: 37777118
When I say I loose pings, I don't loose all. Sometimes the network is ok.

Yes, the router's ISP has a firewall (but I think is manual configured). But like I said sometimes happen, not always, just when everybody is connected. Can be a machine generating bad traffic?
0
 
LVL 11

Expert Comment

by:Khandakar Ashfaqur Rahman
ID: 37777455
This is might be the problem of routing or firewall.This isn't the VLAN issue at all.
You need to check your routers interface statistics,memory and CPU usage and firewall settings.However these features depend on your routers model and brand.

Also please check router's interface.Is it configured Auto,Half Duplex or Full Duplex?
0
 

Author Comment

by:goncalogirao
ID: 37777488
I have access to stats (memory, cpu, sessions and policies below 40%) It is configured 100 FDx.

the firewall settings is what keeps me confused.
0
 
LVL 11

Expert Comment

by:Khandakar Ashfaqur Rahman
ID: 37777648
Did you try with restarting the interface or reboot the router?
0
 

Author Comment

by:goncalogirao
ID: 37777658
several times. We have changed the private lan interface also 0/3 to 0/0.

I'm considering change the router.
0
 
LVL 6

Expert Comment

by:RKinsp
ID: 37777677
can you see if there are any errors on the Router/Firewall interface? what model equipment is it?
0
 
LVL 11

Expert Comment

by:Khandakar Ashfaqur Rahman
ID: 37777732
It could be the firewall issue.
Did you try ping from WAN side when you encounter problem??

If it is your border router you could try from looking glass sites:
http://lg.level3.net/ping/ping.cgi              

You can use 99 packet count to check if there's any drop.
0
 

Author Comment

by:goncalogirao
ID: 37777749
Great tip! Pinging from outside....
0
Scale it in WD Gold

With up to ten times the workload capacity of desktop drives, WD Gold hard drives employ advanced technology to deliver among the best in reliability, capacity, power efficiency and performance.

 
LVL 11

Expert Comment

by:Khandakar Ashfaqur Rahman
ID: 37779325
So, it could be your router feature specially firewall.
0
 

Author Comment

by:goncalogirao
ID: 37779343
now its late night here, and no one at office. Tomorrow give feedback
TY
0
 

Author Comment

by:goncalogirao
ID: 37780755
Today tested the ping from outside, no problems at all. The router is a Cisco Juniper
0
 
LVL 11

Expert Comment

by:Khandakar Ashfaqur Rahman
ID: 37780766
Could you please disable your firewall (for test only) ?
0
 

Author Comment

by:goncalogirao
ID: 37796939
I Cannot disable FW because its not configured manually. I'm considering config a LACP for better performance.
0
 
LVL 11

Expert Comment

by:Khandakar Ashfaqur Rahman
ID: 37797055
That would be good.Just go ahead.
0
 

Author Comment

by:goncalogirao
ID: 37797515
I've found "A device on port 21 is transmitting packets shorter than 64 bytes or longer than 1518 bytes (longer than 1522 bytes if tagged), with valid CRCs." And many other ports on one switch. Already upgraded the nics driver with no luck. How can I prevent it?

I have about 4000 Rx errors on 8 ports...
0
 
LVL 6

Expert Comment

by:RKinsp
ID: 37797544
Can you capture the packet to see if it is a valid packet? You might have to enable Jumbo Frames if it is valid (bigger packets, up to 9000 bytes).

-RK
0
 
LVL 11

Expert Comment

by:Khandakar Ashfaqur Rahman
ID: 37797569
Check MTU settings of your devices.
0
 

Author Comment

by:goncalogirao
ID: 37800193
All errors come from Realtek PCIe Gigabit Family NICs (about 8). Today I asked my collaborators to use wireless instead of cable to check network performance.
0
 

Author Comment

by:goncalogirao
ID: 37805245
I enabled jumbo frames on that clan, but was no good. I think i lost even more performance. I'm going to check mtu on devices, they should be at 1500?

You are great with your help!
0
 
LVL 11

Accepted Solution

by:
Khandakar Ashfaqur Rahman earned 500 total points
ID: 37805445
Hello,

MTU vaies based on media.Please check the following link and MTU Table of common media:
http://en.wikipedia.org/wiki/Maximum_transmission_unit
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Many network operators, engineers, and administrators do not take several factors into consideration when troubleshooting network throughput and latency issues.  They often  measure the throughput by performing a measurement  by transferring a large…
As dyndns has reduced the capabilities of the free service, I looked around for other free providers of Dynamic DNS service. After testing several I decided to move my DNS hosting to Hurricane Electric as then domains that require dynamic hostnam…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now