Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

InfoPath Client Form Link to New Form does not work for SharePoint 2010

Posted on 2012-03-27
5
Medium Priority
?
1,556 Views
Last Modified: 2012-04-04
We have a SharePoint 2007 Environment and are using InfoPath 2010. When I publish a form in the Infopath 2010 format, users cannot open the form via a link (http://mysite/sites/formlibrary/myform.xsn). They recieve an error and the form does not open. In order to get this to work, I we have to use the InfoPath 2007 format.  We are now upgrading to SharePoint 2010 and now all links we have to our InfoPath 2007 forms are not working - presumably because they are in the InfoPath 2007 format. Is there a workaround, or do we have to change all the 2007 forms to 2010 forms (which I loath to do, since that involves recreating the data connections). thanks so much!
0
Comment
Question by:janicet123
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 28

Expert Comment

by:clayfox
ID: 37774304
2010 is backward compatible with 2007 version templates.

I would guess it is more likely that the URL to your template locations in Mysites changed when you upgraded.

One test is publish to a file share a form and then test opening it etc.  To prove that 2010 is backward compatible. then I would look at the links you are using in your forms and verify them by going to them manually and see if they really still work as written.
0
 
LVL 7

Author Comment

by:janicet123
ID: 37774437
The issue is that if the link to the xsn is published to a links list (or email, or in a CEWP), I recieve a pop up that the form cannot be edited in the browser because it is not browser compatible. It is as if that link is forcing the form to open in the browser. No locations have changed - this happens even if the link is configured in a 2010 environment. This even happens when the library is configured to force forms to open in the client application. Your thoughts are appreciated. :)
0
 
LVL 28

Accepted Solution

by:
clayfox earned 2000 total points
ID: 37774454
Hey Janice, did not notice it was you at first.

ok, so it is defaulting to the browser rather than the client in SP2010.

It may be due to that you are opening it from a link in a list but not sure.  The default behavior is supposed to be to open in the client not the browser.  Make sure InfoPath filler is the default program for opening xsn files.

Here is some more discussion on how to force it.
http://social.msdn.microsoft.com/forums/en-us/sharepointinfopath/thread/27CEADA2-A320-4D43-9424-0500BC1AAF8F
0
 
LVL 7

Author Comment

by:janicet123
ID: 37777515
Hi Clay! Nice to hear from you - thanks for remembering me!

In our environment, because of permissions, we frequently publish a form template to a document library (using Publish to Network drive option) that everyone has permissions to and then also to a form library where we can use an email submit option. This way, responses can be kept confidential. We usually send out the link to the template via email. The problem is that this link wants to open up in a browser, even when the form is not browser compatible. This works fine in 2007, but in our 2010 test environment it fails.

The "force" you sent me seems like it could work, but can you help me clarify the syntax? I tried a couple ways but could not get it to work.

The syntax in the post was:

http://{YOUR-SERVER}/_layouts/FormServer.aspx?XmlLocation=YOURFORM.xml&Source={FORMSOURCE}&DefaultItemOpen=0

Does this mean that if my link to the xsn is http://JanicesSite/JanicesLibrary/JanicesForm.xsn, the previous syntax should be modified as follows:

 http://JanicesSite/_layouts/FormServer.aspx?XmlLocation=JanicesForm.xml&Sourcehttp://JanicesSite/JanicesLibrary/JanicesForm.xsn&DefaultItemOpen=0

I got an error indicating that it did not like the reletive URL, but maybe I did something wrong?

Thanks for your help with this!
0
 
LVL 7

Author Closing Comment

by:janicet123
ID: 37806593
Thanks Clay - we found that the issue is due to IE9. Apparently the User-Agent string changed with IE9. InfoPath forms that are designed to open in the InfoPath client (instead of opening in the web browser) are dependent on the IE8 User-Agent string behavior.  Because a number of other apps are depending on the IE8 behavior, IE9 prevents such apps from breaking by shipping with Display intranet sites in Compatibility View enabled. I am sure your workaround would have worked, if I had the technical expertise to configure it. :) Thanks for your help!
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you create your solutions on SharePoint sooner or later you will come upon a request to set  permissions of the item depending on some of the item's meta-data - the author, people assigned as approvers, divisions, categories etc. The most natu…
Before you can digitally sign infopath forms, you must have a digital certificate. Microsoft Certificate Services will need to be enabled on a Windows Server 2008 to facilitate the creation and verification of the digital certifciates on the web ser…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question