Problem setting up a new shadow copy on a volume

I am trying to set up shadow copies on a volume but cannot select the correct volume in the storage area.

I have a volume assigned to the drive letter F:  I select the setting to assign the limit and the location.  I would usuually store the shadow copy on the same volume.  The drop down does not list my volume.

I have attached a print screen of the setting for the volume.
TmakiWITCAsked:
Who is Participating?
 
TmakiWITCAuthor Commented:
We have four servers with the same configuration and they all had the same problem.  I really don't want to remove the volume and recreate it as it is being used.  
The other items that I should have mentioned are that these are Hyper-V virtual servers.  There are two clustered hosts with shared storage.  

I am not sure if this is a byproduct and the reason this is happening.  I have never seen it before except this situation.

Since we are already using the volume we set up the shadow copy to reside on a separate volume.  This seems to be working fine.

Thanks for the help!
0
 
GeodashCommented:
No screenshot attached
0
 
dave4dlCommented:
Try using hobocopy.  Download here: https://github.com/candera/hobocopy
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
TmakiWITCAuthor Commented:
0
 
noxchoGlobal Support CoordinatorCommented:
Can you also post the screen shot of Windows Disk Management?
0
 
TmakiWITCAuthor Commented:
This is a screen shot of the Disk Configuration
Disk-Config.JPG
0
 
noxchoGlobal Support CoordinatorCommented:
Delete F: and recreate it. Your partition is a mess. Look the size of it - 100MB? And disk layout says different size. This happens when PartMgr fails to update the partition info in Windows registry.
If you have data on F: drive then copy it out first.
0
 
TmakiWITCAuthor Commented:
I will try this and post my results, thanks.   I need to do this after hours as it is in production.
 I did not see the 100 MB in the Disk Management screen.   I was always looking at the graphic representation and that is correct.
0
 
TmakiWITCAuthor Commented:
I believe our problem is that we are using disk quotas of 100MB on the volume we cannot set up Shadow copy on.  It is fine if we remove the disk quota.  Once we add the disk quota back on we cannot add the shadow copy.  
I did remove the disk quota and created the shadow copy and then set the disk quota again without any problems.  But I am afraid that the shadow copy will have problems.  
Is there any documentation that explains the problem with setting up a shadow copy for a volume that will use disk quotas?
0
 
noxchoGlobal Support CoordinatorCommented:
What is the quota you set? Does it take half of the free space?
And btw, does the wrong size depiction change if you remove the quota?
0
 
TmakiWITCAuthor Commented:
The quota is 100 MB, no it does not take half the free space.  Yes, it does correct the wrong size depiction when you remove the quota.  The wrong size changes to the quota size when applied.
0
 
noxchoGlobal Support CoordinatorCommented:
Interesting. I have test Win 2003 at work. Will check on it tomorrow if quoting makes the difference.
0
 
noxchoGlobal Support CoordinatorCommented:
The quota is 100 MB, no it does not take half the free space.  Yes, it does correct the wrong size depiction when you remove the quota.  The wrong size changes to the quota size when applied.
I set the quota on 40GB drive limiting the size to 100MB. And the drive in WDM shows as 40GB still. Plus it is available in Shadow Copies list. Try to delete and recreate it as I suggested before.
0
 
TmakiWITCAuthor Commented:
I was not willing to test other solutiion and this work around seems to work just fine.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.