Exchange 2010 – how do I set up a smtp relay on my exchange 2010 server?

I have been advised by my vendor:

“to enable the emails to get through, you will need to enable SMTP relay on your Exchange server from the IP address of the ###### server”

Please advise how this is done. Also will there be any downtime as I cannot have any downtime during business hours. Please advise.
gpersandAsked:
Who is Participating?
 
KalluSureshKumarConnect With a Mentor Commented:
Simple , no down time.

Exchange Management Console --> Server Configuration --> Hub Transport. (Dont touch the default receive connector)

Right click in the Receive connectors pane and select new receive connector. Give it some name like "Relay"  from Customer from the drop down list. Click next.

Remote Network settings --> Delete all the IP and add only IP which you would like to authorize to relay e-mail from your server. Click next . click new. Click Finish

From the new receive connector properties:

On the Permission Groups tab : only select Exchange servers.

On Authentication tab :  Only select "Externally Secured (for example, with IPSsec).

Click OK and try  to relay emails through your server.

Let me know if this helps :-)
0
 
Red_TechCommented:
Your 'Connector' may have a different name.

SMTP Relay
0
 
chakkoCommented:
You need to setup a connector.

Is this relay for your server to send mail out, or is it to allow an external server/user to send mail through to your server?   The difference is if you require a SEND or a RECEIVE connector.

It does not require downtime to do this.  

In the properties of the connector there is an area to set the IP Address for relaying if you need that.  In the Hub transport area for the receive connectors.  Go to properties, then look on the network tab.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
gpersandAuthor Commented:
Thanks guys. I will test and update asap.
0
 
gpersandAuthor Commented:
FYI this is for a internal linux server that needs to send mails out via our exchnage server.

Do I create a send connector??

Where do I do this?
0
 
KalluSureshKumarCommented:
Hello Sir..

Please read my comment above and follow step by step , you should be able to achieve this.

You don't have to create sent connector its a receive connector which will receive email from Linux and relay via exchange.

So from the above step you need to add the linux server ip address

Remote Network settings --> Delete all the IP and add only IP (linux server ip) which you would like to authorize to relay e-mail from your server. Click next . click new. Click Finish
0
 
gpersandAuthor Commented:
KalluSureshKumar
I am trying to create a connector although I am asked for a FQDN to respond. is this just my exchange server FQDN?
0
 
gpersandAuthor Commented:
KalluSureshKumar

Thankyou I have done as instructed and have asked my vendor to test. I will let you know the outcome.
0
 
gpersandAuthor Commented:
I have also done this as instructed. Is that right??

On the Permission Groups tab : only select Exchange servers.

On Authentication tab :  Only select "Externally Secured (for example, with IPSsec).
0
 
KalluSureshKumarCommented:
Telnet to port 25 i get the following respond in my exchange 2010 machine:

220 2K10.2k10.com Microsoft ESMTP MAIL Service ready ............................

What would you like to change , if its only 2k10.2k10.com to different FQDN then change the FQDN in the receive connector.

If you want to change the whole string then you might have to change the banner :

You can use Set-Receiveconnector -Identity <> -Banner <>

http://technet.microsoft.com/en-us/library/bb125140.aspx
0
 
KalluSureshKumarCommented:
yes

On the Permission Groups tab : only select Exchange servers.

On Authentication tab :  Only select "Externally Secured (for example, with IPSsec).
0
 
KalluSureshKumarCommented:
were you able to test the relay connector?
0
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
0
 
chakkoCommented:
Since you want a Linux server to relay through your Exchange you should set Anonymous for the security permissions.
0
 
KalluSureshKumarCommented:
I disagree with "chakko"  irrespective of application. Any application which needs to relay from Exchange Permissions "Exchange Server" and Authentication "Externally secured will suffice.

If you enable Anonymous you will receive email but will not able relay. To relay you need to explicit command line to enable relay.
0
 
gpersandAuthor Commented:
Following the instructions by KalluSureshKumar the relay has been tested and it seems to be fine so I will award the points accordingly.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.