Solved

RDP to internal workstation

Posted on 2012-03-27
9
569 Views
Last Modified: 2012-03-30
Hi
I am having a problem accessing RDP on a workstation within a domain.
The workstation can be remoted internally OK but not from an external source.
I have port redirection for port 3389 to the static IP of the workstation.

If I do a port scan for port 3389 to the public ip of the router it is not open.
If I change the port forwarding to the server itself the port scan is successful.

I have tried with the firewall on the workstation off but still the same result.
I also cannot connect if I VPN into the network and attempt to RDP.

This was working a liitle whil back ok but perhaps a security update may have been applied that is now blocking it.

Any thoughts?
0
Comment
Question by:karbec
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 8

Expert Comment

by:hunart
ID: 37774635
Do you have any antivirus software or third party firewall software installed on the local workstation?  If you do, it might be blocking accessing from an external connection.
0
 
LVL 4

Expert Comment

by:ltsweb
ID: 37774640
If you are running windows 7, the firewall can be configured for domain, local, and public access.  Did you try to turn off all firewalls?  It sounds like a firewall issue from windows or a third party av like Norton.
0
 
LVL 9

Expert Comment

by:MBobrek
ID: 37774704
Check firewall/blocked ports.
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 

Author Comment

by:karbec
ID: 37775567
Thanks for responses.
I had the AVG firewall disabled but found that the Windows firewall was on also.
It looks like Windows firewall is being enabled by GP or something as I am unable to disable it even when logged in as domain administrator.

I found the following procedure but it makes no difference.

On server.
Computer Config > Administrative Templates > Network > Network connections > Windows Firewall > Domain Profile  > Windows Firewall: Protect all network connections = Disabled
After that go to client machine;
Start > Run > CMD > Gpupdate /force
Reboot.

For added information the workstation is Windows XP Prof. with SP3.
The server is SBS 2011.

Thanks.
0
 
LVL 4

Expert Comment

by:ltsweb
ID: 37776163
In the Sbs console, go to computers and add the user to the computer for remote admin.

You may need to go to users and check that the user has rdp access and VPN.
Under users, there is a computer link, add the computer to that users account.

I think you can go to computers and add multiple users if that is what you need.

Go to https://your domain.com/remote and login to the Sbs remote workplace, your computer should be on list.  If not, go back to Sbs console and check what is going on under computers.
0
 
LVL 8

Expert Comment

by:hunart
ID: 37776327
Are the OUs for your servers part of the GPO?  Check the GPO settings on your AD and make the changes from there, not from you severs.
0
 

Author Comment

by:karbec
ID: 37779474
Hi Itsweb
Yes, the user had been given access to the computer in SBS console and also checked in AD to ensure they had access there also.
I can remote ok using "https://remote.domain.com.au" and can shortcut to "https://remote.domain.com.au/Remote/rdp" but was hoping to RDP directly as a lot simpler and a bit quicker for the user.

hunart, yes the OU for the server is in the GPO . I have been through all applied GPs to to ensure none are enable and all are not applied. I disable the "Windows Firewall: Protect all network connections" in the Default Domain Policy.

As this is SBS server there is only the one domain server.

The RDP firewall exception in the XP firewall indicates is has been applied by GP but I cannot for the life of me figure out where it is being applied. There must be a way of over-riding this but if not I'll have to go with just using a shortcut to RDP via remote website.

Thanks for you assistance so far.
0
 
LVL 8

Accepted Solution

by:
hunart earned 500 total points
ID: 37781465
Can you run this command and post the results:

gpresult /v

You can redirect the file to a text file; use this command:

gpresult /v > C:\yourfile.txt

This command will tell you what GPO is being applied to the local machine, the one which you are having problem with.  There must be a policy that is being applied somewhere that you are not aware of.
0
 

Author Closing Comment

by:karbec
ID: 37789678
Thanks hunart

That pointed me in the right direction. The gpresults showed a couple GPOs that I wasn't aware of, a couple of which had "Windows Firewall: Protect all network connections = Enabled .
I disabled these and connecting with RDP now works fine.

    Applied Group Policy Objects
    -----------------------------
        Windows SBS CSE Policy
        Windows SBS Client - Windows XP Policy
        Windows SBS Client Policy
        Default Domain Policy
        Update Services Client Computers Policy
        Update Services Common Settings Policy

That's one helpful command to remember.

Thanks again hunart and all others who offered solutions.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
Configuring network clients can be a chore, especially if there are a large number of them or a lot of itinerant users.  DHCP dynamically manages this process, much to the relief of users and administrators alike!
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question