Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

activesync 2010 - invalid username and password and error 401

Posted on 2012-03-28
5
2,561 Views
Last Modified: 2012-07-01
TMG and green tick when test rule - worked fine with ISA

now with ex10 and TMG - no good

i do notice 401 error when i run test as below

all my TMG rules are working green tick

bu error 401

Time reported by the Microsoft Forefront TMG Firewall Service: 0.006 seconds
HTTP response: 401 Unauthorized
The test successfully completed for this URL.
0
Comment
Question by:philb19
  • 4
5 Comments
 

Author Comment

by:philb19
ID: 37775539
external test i get this




      Connectivity Test Failed
 
Test Details
      ExRCA is testing Exchange ActiveSync.
       The Exchange ActiveSync test failed.
       
      Test Steps
       
      Attempting to resolve the host name lcex10a.landcorp.com.au in DNS.
       The host name resolved successfully.
       
      Additional Details
       IP addresses returned: 116.212.196.132
      Testing TCP port 443 on host lcex10a.landcorp.com.au to ensure it's listening and open.
       The port was opened successfully.
      Testing the SSL certificate to make sure it's valid.
       The certificate passed all validation requirements.
       
      Test Steps
       
      ExRCA is attempting to obtain the SSL certificate from remote server lcex10a.landcorp.com.au on port 443.
       ExRCA successfully obtained the remote SSL certificate.
       
      Additional Details
       Remote Certificate Subject: CN=exchcas.landcorp.com.au, OU=it, O=Landcorp, L=perth, S=Western Australia, C=AU, Issuer: CN=DigiCert High Assurance CA-3, OU=www.digicert.com, O=DigiCert Inc, C=US.
      Validating the certificate name.
       The certificate name was validated successfully.
       
      Additional Details
       Host name lcex10a.landcorp.com.au was found in the Certificate Subject Alternative Name entry.
      Testing the certificate date to confirm the certificate is valid.
       Date validation passed. The certificate hasn't expired.
       
      Additional Details
       The certificate is valid. NotBefore = 2/14/2012 12:00:00 AM, NotAfter = 4/18/2013 12:00:00 PM
      Checking the IIS configuration for client certificate authentication.
       Client certificate authentication wasn't detected.
       
      Additional Details
       Accept/Require Client Certificates isn't configured.
      Testing HTTP Authentication Methods for URL https://lcex10a.landcorp.com.au/Microsoft-Server-ActiveSync/.
       The HTTP authentication methods are correct.
       
      Additional Details
       ExRCA found all expected authentication methods and no disallowed methods. Methods found: Basic
      An ActiveSync session is being attempted with the server.
       Errors were encountered while testing the Exchange ActiveSync session.
       
      Test Steps
       
      Attempting to send the OPTIONS command to the server.
       Testing of the OPTIONS command failed. For more information, see Additional Details.
       
      Additional Details
       An HTTP 401 Unauthorized response was received from the remote ISA server. This is usually the result of an incorrect username or password. If you are attempting to log onto an Office 365 service, ensure you are using your full User Principal Name (UPN).


© 2011 Microsoft | Version 1.3 | Feedback | Privacy | Legal
Error
ExRCA has encountered an error.

The entire error report is listed below. Show Report  Hide Report

Copy error details to the Clipboard
No Additional Error Details

Close
Error

This field is required.
0
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 37779207
You have set the TMG publishing rule to use FORMS?
How are you entering the credentials, what format?
Have you set the default domain name in the Exchange environment?

Are you running the Exchange edge service on the TMG itself?
0
 

Author Comment

by:philb19
ID: 37779918
hi html form authent on the listner for rule - yes

credentials domian\username

Have you set the default domain name in the Exchange environment?
what does this mean - how to do please?


Are you running the Exchange edge service on the TMG itself? NO edges service at all anywhere
0
 

Accepted Solution

by:
philb19 earned 0 total points
ID: 38127877
fixed by setting correct url on the exchange server 2010
0
 

Author Closing Comment

by:philb19
ID: 38142558
fixed myself
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

792 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question