Terminal server access restriction

I need to grant terminal server access to a specific group of users with limited rights(only shutdown, log off and Restart) through Group policy.

 Please advice
psanjoySystem AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tony JLead Technical ArchitectCommented:
You need to create a group policy to apply to your terminal servers.

Ideally, these should be in their own OU.

Apply the restrictive group policy to your users, or preferrably a group they are members of, and turn on loopback group policy processing.

Then knock yourself out with the policies - tweak them down as tight as you want, but bear in mind if you go too far you may prevent them being able to do anything at all.
0
psanjoySystem AdministratorAuthor Commented:
Thanks for your support.

I have created a GP object and linked to servers OU. How can I link same to a specific group of users?
0
Tony JLead Technical ArchitectCommented:
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tony JLead Technical ArchitectCommented:
Oh remember there'll be a time delay before the policies take affect and some (machine based) may require a restart of the servers whilst others (user based) may require a logoff and logon to take affect.

Worth bearing in mind if you have a policy or two that don't appear to kick in.

Also - you may want to be careful. When you say you've applied the policy to the servers OU if this is all servers and not just terminal servers, it'll apply across them all and you may get unintended results.
0
psanjoySystem AdministratorAuthor Commented:
Thanks for your support.

I have created a GP object and linked to servers OU and applied to a specific group. I added effective user to the Remote Desktop users group of linked servers  too.

But still the policy doesnt work properly. pls help me
0
Tony JLead Technical ArchitectCommented:
Which settings did you apply?

If they are computer settings, remember to enable loopback policy processing in the group policy.
0
psanjoySystem AdministratorAuthor Commented:
User configuration-> Admin Templates-> Start menu and Taskbar then provided restricions.
0
Tony JLead Technical ArchitectCommented:
Not being overwritten by other policies?

On one of the servers, can you log in as one of the (non) affected users and run rsop.msc ?

This will then tell if the policies are at least being deployed.
0
psanjoySystem AdministratorAuthor Commented:
How can I provide SHUTDOWN permissions to Remote desktop users..?
0
Tony JLead Technical ArchitectCommented:
Group policy.

But it's there by default and the following removes it:

Computer Configuration > Administration Templates > System > Remove boot/ Shutdown/ logon / logoff status

Respecfully though, that's a separate issue to the one you originally raised and really should be a new question.
0
psanjoySystem AdministratorAuthor Commented:
First of all, I am really sorry if I have confused you.

My exact requirement is that we have few site offices with ISA servers. I just need to provide 'Shutdown privilege only' to Site -IT Administrators only these ISA servers.

Therefore, I have created separate OU on Active directory and added those ISA server into that.

Please help me to create a GP with only SHUTDOWN rights on Remote Desktop access to these servers.
0
Tony JLead Technical ArchitectCommented:
Actually the apology is mine - I was confusing your question with a very similar one (title) that I'd been answering!

Ah I think I see what you require but correct me if I'm wrong:

Remove all privileges but allow the users in question to shut down the ISA servers?

If this is the case, you'd need to basically create an OU (I see you've done that), apply a group policy that will apply the restrictions you require and if necessary, block inheritance to prevent these changes being overwritten.

Have you tried your setting already? What do the users see (or not see)?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
psanjoySystem AdministratorAuthor Commented:
I have done the below configurations on GPO for the AD group and server container.. Please check.

* I have created a separate OU and moved these ISA servers into that.
* Created a AD group called 'Site Admin' and added the users then associated this group to Security filtering of the GPO.
* Linked ISA Servers OU to newly created GPO (User config -> Administrative Templates -> Start Menu&Taskbar with restrictions)
* Added the users to 'Remote desktop users' group of the member servers.

Still the GPO policies are not getting activated. please assist me to resolve.
0
psanjoySystem AdministratorAuthor Commented:
I configured the above settings in GPO, but still the policies are not getting replicated. pls assist me to resolve the issues..
0
psanjoySystem AdministratorAuthor Commented:
It is working now. Thanks for your valuable comment.  You can close the case
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.