Solved

Ricoh Aficio 2022 - Scan to email not working

Posted on 2012-03-28
9
1,917 Views
Last Modified: 2012-03-28
Hi all

My Ricoh Aficio 2022 was working perfectly for approx 6 months but in the last couple of months the scan to email option has stopped working altogether. The printer and copy options are still working, but when I load a document and go to scan it to email the machine acts as if it has worked, as in the memory percentage drops as the scanner scans the document and then returns to normal, there's no error on the Ricoh itself.
When I look in my email server logs the below is logged;

Socket error sending response to DATA
Winsock Error 10054 Connection was reset by the other side!


I have an internal mDaemon email server and all the addresses I am trying to send to are local. I set up an email account for the Ricoh and have tried turning on and off the POP before SMTP and the SMTP authentication options but I get the same results, in fact even with the SMTP authentication turned on I am not seeing any log of the authentication in the email server logs. The email server is working perfectly and there are no network issues at all.

Has anyone else seen this before and can you advise.

As always many thanks in advance for you help
0
Comment
Question by:LukeFileWalker
  • 5
  • 4
9 Comments
 
LVL 8

Expert Comment

by:haoss
ID: 37776195
hi,
I found this :
http://www.altn.com/Support/KnowledgeBase/KnowledgeBaseResults/?Number=KBA-02012

can you post all log from mdaemon.
0
 

Author Comment

by:LukeFileWalker
ID: 37776281
Thanks Haoss

I don't think that's the issue as both the Ricoh and email server are on the same LAN and the IP address range they are on is trusted by the MD server. Basically I've switched off every security feature for the email address/IP address of the Ricoh machine and I still get the same results, see logs below.


Tue 2012-03-27 12:13:40: ----------
Tue 2012-03-27 12:13:40: [100983:4] Session 100983; child 4
Tue 2012-03-27 12:13:40: [100983:4] Accepting SMTP connection from [10.0.0.203:1036] to [10.0.0.241:25]
Tue 2012-03-27 12:13:40: [100983:4] --> 220-ESMTP Tue, 27 Mar 2012 12:13:40 +0100
Tue 2012-03-27 12:13:40: [100983:4] --> 220-Spammers are not welcome here.
Tue 2012-03-27 12:13:40: [100983:4] --> 220 You know who you are!!
Tue 2012-03-27 12:13:40: [100983:4] <-- HELO Ricoh
Tue 2012-03-27 12:13:40: [100983:4] --> 250 mail.mydomain.com Hello Ricoh, pleased to meet you
Tue 2012-03-27 12:13:40: [100983:4] <-- MAIL FROM:<STF@mydomain.com>
Tue 2012-03-27 12:13:40: [100983:4] --> 250 <STF@mydomain.com>, Sender ok
Tue 2012-03-27 12:13:40: [100983:4] <-- RCPT TO:<John@mydomain.com>
Tue 2012-03-27 12:13:40: [100983:4] --> 250 <John@mydomain.com>, Recipient ok
Tue 2012-03-27 12:13:40: [100983:4] <-- DATA
Tue 2012-03-27 12:13:40: [100983:4] Creating temp file (SMTP): temp\50\md50000000175.tmp
Tue 2012-03-27 12:13:40: [100983:4] --> 354 Enter mail, end with <CRLF>.<CRLF>
Tue 2012-03-27 12:13:40: [100983:4] Message size: 196198 bytes
Tue 2012-03-27 12:13:40: [100983:4] Passing message through AntiVirus (Size: 196198)...
Tue 2012-03-27 12:13:40: [100983:4] *  Message is clean (no viruses found)
Tue 2012-03-27 12:13:40: [100983:4] ---- End AntiVirus results
Tue 2012-03-27 12:13:40: [100983:4] Socket error sending response to DATA
Tue 2012-03-27 12:13:40: [100983:4] *  Winsock Error 10054 Connection was reset by the other side!
Tue 2012-03-27 12:13:40: [100983:4] SMTP session terminated (Bytes in/out: 196316/310)
Tue 2012-03-27 12:13:40: ----------


I then excluded this address from Antivirus Scanning on the MD server


Tue 2012-03-27 13:14:48: ----------
Tue 2012-03-27 13:14:48: [3579:2] Session 3579; child 2
Tue 2012-03-27 13:14:48: [3579:2] Accepting SMTP connection from [10.0.0.203:1045] to [10.0.0.241:25]
Tue 2012-03-27 13:14:48: [3579:2] --> 220-ESMTP Tue, 27 Mar 2012 13:14:48 +0100
Tue 2012-03-27 13:14:48: [3579:2] --> 220-Spammers are not welcome here.
Tue 2012-03-27 13:14:48: [3579:2] --> 220 You know who you are!!
Tue 2012-03-27 13:14:48: [3579:2] <-- HELO Ricoh
Tue 2012-03-27 13:14:48: [3579:2] --> 250 mail.mydomain.com Hello Ricoh, pleased to meet you
Tue 2012-03-27 13:14:48: [3579:2] <-- MAIL FROM:<STF@mydomain.com>
Tue 2012-03-27 13:14:48: [3579:2] --> 250 <STF@mydomain.com>, Sender ok
Tue 2012-03-27 13:14:48: [3579:2] <-- RCPT TO:<John@mydomain.com>
Tue 2012-03-27 13:14:48: [3579:2] --> 250 <John@mydomain.com>, Recipient ok
Tue 2012-03-27 13:14:48: [3579:2] <-- DATA
Tue 2012-03-27 13:14:48: [3579:2] Creating temp file (SMTP): temp\42\md50000000007.tmp
Tue 2012-03-27 13:14:48: [3579:2] --> 354 Enter mail, end with <CRLF>.<CRLF>
Tue 2012-03-27 13:14:48: [3579:2] Message size: 52582 bytes
Tue 2012-03-27 13:14:48: [3579:2] Passing message through AntiVirus (Size: 52582)...
Tue 2012-03-27 13:14:48: [3579:2] *  Recipient or sender in exclusion list
Tue 2012-03-27 13:14:48: [3579:2] ---- End AntiVirus results
Tue 2012-03-27 13:14:48: [3579:2] Socket error sending response to DATA
Tue 2012-03-27 13:14:48: [3579:2] *  Winsock Error 10054 Connection was reset by the other side!
Tue 2012-03-27 13:14:48: [3579:2] SMTP session terminated (Bytes in/out: 52679/295)
Tue 2012-03-27 13:14:48: ----------
0
 
LVL 8

Expert Comment

by:haoss
ID: 37776447
can you exclude it also from spam filter.
0
 
LVL 8

Expert Comment

by:haoss
ID: 37776526
have you changed any configuration in Ricoh or mail server??
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 8

Accepted Solution

by:
haoss earned 500 total points
ID: 37776562
0
 

Author Comment

by:LukeFileWalker
ID: 37776575
It's already excluded from the spam filter. I haven't made any changes at all to either, it was basically working fine one day and not the next.
The weird thing is that even though the Ricoh is set to use SMTP Authentication this doesn’t appear in the SMTP log on the MD server.
I’ve even used telnet to log onto the email server and have sent a number of emails from Ricoh’s email address to my own and that works without any issue.
0
 

Author Comment

by:LukeFileWalker
ID: 37776671
Below is a log from when it was working and the DeliverIfConnectionAborts was set to No on mDaemon, plus the email was passed through Anti Virus


Wed 2012-03-07 12:00:37: [116464:2] Session 116464; child 2
Wed 2012-03-07 12:00:37: [116464:2] Accepting SMTP connection from [10.0.0.203:1486] to [10.0.0.241:25]
Wed 2012-03-07 12:00:37: [116464:2] --> 220-ESMTP Wed, 07 Mar 2012 12:00:37 +0100
Wed 2012-03-07 12:00:37: [116464:2] --> 220 Spammers are not welcome here.
Wed 2012-03-07 12:00:37: [116464:2] <-- HELO Ricoh
Wed 2012-03-07 12:00:37: [116464:2] --> 250 mail.mydomain.com Hello Ricoh, pleased to meet you
Wed 2012-03-07 12:00:37: [116464:2] <-- MAIL FROM:<STF@mydomain.com>
Wed 2012-03-07 12:00:37: [116464:2] --> 250 <STF@mydomain.com>, Sender ok
Wed 2012-03-07 12:00:37: [116464:2] <-- RCPT TO:<John@mydomain.com>
Wed 2012-03-07 12:00:37: [116464:2] --> 250 <John@mydomain.com>, Recipient ok
Wed 2012-03-07 12:00:37: [116464:2] <-- DATA
Wed 2012-03-07 12:00:37: [116464:2] Creating temp file (SMTP): temp\28\md50000000240.tmp
Wed 2012-03-07 12:00:37: [116464:2] --> 354 Enter mail, end with <CRLF>.<CRLF>
Wed 2012-03-07 12:00:37: [116464:2] Message size: 142187 bytes
Wed 2012-03-07 12:00:37: [116464:2] Passing message through AntiVirus (Size: 142187)...
Wed 2012-03-07 12:00:37: [116464:2] *  Message is clean (no viruses found)
Wed 2012-03-07 12:00:37: [116464:2] ---- End AntiVirus results
Wed 2012-03-07 12:00:37: [116464:2] Message creation successful: inbound\24\md50000012841.msg
Wed 2012-03-07 12:00:37: [116464:2] --> 250 Ok, message saved <Message-ID: 20110601115841K1.DCSML-S001030000.0000747DC82D@mydomain.com>
Wed 2012-03-07 12:00:37: [116464:2] <-- QUIT
Wed 2012-03-07 12:00:37: [116464:2] --> 221 See ya in cyberspace
Wed 2012-03-07 12:00:37: [116464:2] SMTP session successful (Bytes in/out: 142299/402)
Wed 2012-03-07 12:00:37: ----------
0
 

Author Comment

by:LukeFileWalker
ID: 37776802
Hi Hoass

I've changed the DeliverIfConnectionAborts setting from No to Yes and it is working.
I still can't understand why it would work one day with this setting set to No and not the next. Hopefully changing that setting won't lead to a load of duplicate emails.

Many thanks
0
 

Author Closing Comment

by:LukeFileWalker
ID: 37776820
Much thanks
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes you might need to configure routing based not only on destination IP address, but also on a combination of destination IP address (or hostname) and destination port number. I will describe a method how to accomplish this with free tools. …
Are you one of those front-line IT Service Desk staff fielding calls, replying to emails, all-the-while working to resolve end-user technological nightmares? I am! That's why I have put together this brief overview of tools and techniques I use in o…
I designed this idea while studying technology in the classroom.  This is a semester long project.  Students are asked to take photographs on a specific topic which they find meaningful, it can be a place or situation such as travel or homelessness.…
Need to grow your business through quality cloud solutions? With everything required to build a cloud platform and solution, you may feel like the distance between you and the cloud is quite long. Help is here. Spend some time learning about the Con…

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now