Solved

Using Internet Explorer to Access a Moodle Web Site

Posted on 2012-03-28
4
315 Views
Last Modified: 2012-05-29
We have a particularly annoying problem at our school when our students attempt to access a Moodle web site using Internet Explorer 7, 8 or 9 on WinXP and Win 7 computers.

Students are able to access the Moodle web site OK and obtain the login screen.  However when they enter their username and password and click the Login button their login details are wiped out and they are returned to the login screen minus the login details that they entered.  On some occasions they are able to login OK but this seems to be a random occurrence.

However when using Firefox they are able to login to the Moodle web site without any problems.  (Unfortunately we cannot use Firefox at our school because our IT Manager has a policy of using Microsoft Products)

We have tried clearing the Internet Explorer cache of Browsing History and Cookies prior to login but to no avail. The login problem is still there. Can anyone help because I am starting to run out of ideas.
0
Comment
Question by:jbarton2310
  • 2
4 Comments
 
LVL 10

Expert Comment

by:Bawer
ID: 37776377
Open internet explore and go to Tools--->Compatibility View Settings and add mention website which is not compatibile with internet explorer 7, 8 & 9.
0
 

Accepted Solution

by:
jbarton2310 earned 0 total points
ID: 37795852
Have solved the problem.  It appears that students need to enter the www prefix in the URL eventhough they can still get to the same website by not using the www prefix in the URL. (Seems weird but it is the case) Does anyone know the reason why?

When the www prefix to the URL is entered (history needs to be cleared prior to this) the logon works OK.
0
 
LVL 2

Expert Comment

by:musickmann
ID: 37900554
Sounds like it could be related to a few different things. Some more information would help:
Is this a windows or linux server?
What version of moodle?

Another consideration could possible be the template you are using.

I would check the $CFG->wwwroot setting in the config.php file to see what is there as well. I'm not exactly sure why one browser would work and another would not, but since all browsers are not created equally, who knows.
0
 

Author Closing Comment

by:jbarton2310
ID: 38021283
This solution worked.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Several part series to implement Internet Explorer 11 Enterprise Mode
Having trouble getting your hands on Dynamics 365 Field Service or Project Service trial? Worry No More!!!
Viewers will learn how to maximize accessibility options in an Excel workbook for users with accessibility issues.
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question