ORA-01012: not logged on

I am getting the below error. I couln't find any thing in the log and trace files.

ORA-01012: not logged on

Please advice.
dba1234Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slightwv (䄆 Netminder) Commented:
You have either not logged in or something closed your connection.

What application/program/??? is generating that error?
slightwv (䄆 Netminder) Commented:
Have you checked the description for that error:
http://ora-01012.ora-code.com/
dba1234Author Commented:
I am trying to login on sqlplus "/as sysdba"
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

slightwv (䄆 Netminder) Commented:
Is the databsae started and 'open'?

from the sqlplus prompt type: startup

If it says it is already started try: alter database open;
slightwv (䄆 Netminder) Commented:
I've seen a few posts on other sites that indicate this can also be caused by exceeding the number fo processes.

check the processes spfile parameter.  You might need to increase the value:
http://docs.oracle.com/cd/E11882_01/server.112/e25513/initparams198.htm
dba1234Author Commented:
I tried but getting error.

SQL*Plus: Release 9.2.0.8.0 - Production on Wed Mar 28 10:48:05 2012

Copyright (c) 1982, 2002, Oracle Corporation.  All rights reserved.

Connected.
SQL> startup
ORA-01081: cannot start already-running ORACLE - shut it down first
SQL> shutdown
ORA-24324: service handle not initialized
ORA-24323: value not allowed
ORA-27140: attach to post/wait facility failed
SQL> shutdown abort
ORA-01031: insufficient privilegesseelct * from v%


and after kiiling some of the processes
now I am stucked

SQL> shutdown abort
ORACLE instance shut down.
SQL> startup
ORA-00445: background process "DBW0" did not start after 120 seconds
slightwv (䄆 Netminder) Commented:
Did I ask you to shutdown?  Why did you attempt to shut down in the first place?

Also, you should never use ABORT unless there is absolutely no other way to shut down.

>>and after kiiling some of the processes

This is worse that a shutdown abort.


To get back, might was well abort again:
shutdown abort;

Then from the OS kill any remaining oracle processes.

Then try to startup.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
slightwv (䄆 Netminder) Commented:
What was the final solution to the problem?

I doubt the accepted answer actually solved the question asked.
slightwv (䄆 Netminder) Commented:
Please return to this question and respond to my question.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Oracle Database

From novice to tech pro — start learning today.