Solved

weblogic : OutOfMemoryError: PermGen space

Posted on 2012-03-28
4
1,500 Views
Last Modified: 2012-04-30
hi guys

When i am starting my application using weblogic applications server 10.x
i get this error on my colsole.

Caused by: java.lang.OutOfMemoryError: PermGen space
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
      at weblogic.utils.classloaders.GenericClassLoader.defineClass(GenericClassLoader.java:335)
      at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:288)
      at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:256)
      at weblogic.utils.classloaders.ChangeAwareClassLoader.findClass(ChangeAwareClassLoader.java:54)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:251)


any idea how i can fix this?  I mean how can i fix this in application server?

thanks.
0
Comment
Question by:royjayd
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 20

Expert Comment

by:Sathish David Kumar N
ID: 37780518
Increase your JVM memeory !
0
 
LVL 19

Expert Comment

by:ramazanyich
ID: 37826446
Your outofmemory issue is related to the size of special pool of JVM memory Permanent Generation. You can read more about it on https://blogs.oracle.com/jonthecollector/entry/presenting_the_permanent_generation. In general it contains some objects related to the classes that are used in your JVM. And on application server number of that classes is quite big and doesn't fit into the default size of that permanent generation space.
You can increase memory which is used by that part of JVM heap by adding -XX:MaxPermSize=512M
Do not forget to increase heap size also -Xmx1024M
I would recommend adidng following in the startup options of your server:
-Xmx512M -Xmx1024M -XX:PermSize=256M -XX:MaxPermSize=512M
0
 

Author Comment

by:royjayd
ID: 37829308
What i observed is if i increase the MaxPermSize to 512M it really slows down the system.
I have 3 gb ram.

thx
0
 
LVL 19

Accepted Solution

by:
ramazanyich earned 500 total points
ID: 37829734
Try to use -Xmx2048m
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Configure Web Service (server application) I. Configure security for Web Services methods First, we need to protect Session bean which implements the service: 1. Open EJB deployment descriptor (ejb-jar.xml) in the EJB project that contains you…
Verbose logging is used to diagnose garbage collector problems. By default, -verbose:gc output is written to either native_stderr.log or native_stdout.log.   It is also possible to redirect the logs to a user-specified file. This article will de…
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

634 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question