Where to supply authentication details to the Network Proxy (Central Proxy) on Fedora?

Im running Fedora 16 on my system at the office. We use LAN to connect to the Internet. And for this, we use an http proxy with authentication (username & password). I tried putting the proxyaddress:port in the Network Proxy settings after going to the Network Settings window. However, it never asked for an authentication and the programs that use the internet are unable connect, except for Firefox because it asks for authentication.

Can someone help me out with this problem?

Thank you.
tanopatriceAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
legolasthehansyConnect With a Mentor Commented:
For entering the auth details, try

export http_proxy=http://user:pasword@host.com:port/
etc..
0
 
legolasthehansyConnect With a Mentor Commented:
Do this,
In /etc/profile.d create a file like a_proxy.sh with the followling,

export http_proxy=http://host.com:port/
export ftp_proxy=http://host.com:port/
export no_proxy=.domain.com
export HTTP_PROXY=http://host.com:port/
export FTP_PROXY=http://host.com:port/

save and exit
chmod +x /etc/profile.d/a_proxy.sh

Logout and login (or create a new terminal)
echo $http_proxy (see if the output matches the first line of a_proxy.sh)

Now check if your system takes the proxy settings.
0
 
pclinuxguruConnect With a Mentor Commented:
Close but no cigar:
You missed "authentication" in the op

export http_proxy=http://username:password@host.com:port/

In the network thingy type
 http://username:password@proxyserver

put whatever port they use in the port section.
0
All Courses

From novice to tech pro — start learning today.