Solved

Cisco 2901 and FXO card

Posted on 2012-03-28
8
2,798 Views
Last Modified: 2012-04-02
I have just recently installed new Cisco 2901 routers with VIC2-4FXO cards in them. These routers are used as voice gateways at my branches. All branches are connected to Cisco Call Manager 6.1. After install, users at each branch have been experiencing an intermittant fast busy when dialing out to an external number (we hit 6 to dial externally). This just started happening when I replaced the 2650XM routers at each branch.
0
Comment
Question by:Doug_Ickes
  • 4
  • 4
8 Comments
 
LVL 20

Expert Comment

by:agonza07
ID: 37779596
You may want to upload your configs with any identifiable info removed.

How are the gateways configured H323 of MGCP?

Also you may want to do some debugs while you have a user testing dialing outside.
0
 

Author Comment

by:Doug_Ickes
ID: 37781999
version 15.1
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service compress-config
service sequence-numbers
!
hostname R1-Martinsburg
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200
logging console critical
enable secret 5 ##############################
!
no aaa new-model
clock timezone EST -5 0
clock summer-time EDT recurring
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
ip flow-cache timeout active 1
no ip domain lookup
ip domain name afsb.local
multilink bundle-name authenticated
!
!
!
!
!
!
trunk group 1
 hunt-scheme round-robin
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-XXXXXXXXXX
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-XXXXXXXXXX
 revocation-check none
 rsakeypair TP-self-signed-XXXXXXXXXX
!
!
crypto pki certificate chain TP-self-signed-XXXXXXXXXX
 certificate self-signed 01
 
 
        quit
voice-card 0
!
!
voice call carrier capacity active
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
!
!
!
license udi pid CISCO2901/K9 sn FTX161184RG
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
username admin privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
redundancy
!
!
ip tcp synwait-time 10
ip ssh version 2
!
class-map match-any AutoQoS-VoIP-Remark
 match ip dscp ef
 match ip dscp cs3
 match ip dscp af31
class-map match-any AutoQoS-VoIP-Control-UnTrust
 match access-group name AutoQoS-VoIP-Control
class-map match-any AutoQoS-VoIP-RTP-UnTrust
 match protocol rtp audio
 match access-group name AutoQoS-VoIP-RTCP
!
!
policy-map AutoQoS-Policy-UnTrust
 class AutoQoS-VoIP-RTP-UnTrust
  set dscp ef
  bandwidth percent 50
 class AutoQoS-VoIP-Control-UnTrust
  bandwidth percent 5
  set dscp af31
 class AutoQoS-VoIP-Remark
  set dscp default
 class class-default
  fair-queue
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 ip flow ingress
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 ip flow ingress
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.1
 description Data VLAN
 encapsulation dot1Q 1 native
 ip address x.x.x.x 255.255.255.0
 ip flow ingress
!
interface GigabitEthernet0/0.2
 description Voice VLAN
 encapsulation dot1Q 2
 ip address x.x.x.x 255.255.255.224
 ip helper-address x.x.x.x
 ip flow ingress
 h323-gateway voip interface
 h323-gateway voip bind srcaddr x.x.x.x
!
interface GigabitEthernet0/1
 no ip address
 ip flow ingress
 shutdown
 duplex auto
 speed auto
!
!
router eigrp 71
 network x.x.x.x 0.0.0.255
 network x.x.x.x 0.0.0.31
 network x.x.x.x
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 x.x.x.x 200
!
ip access-list extended AutoQoS-VoIP-Control
 permit tcp any any eq 1720
 permit tcp any any range 11000 11999
 permit udp any any eq 2427
 permit tcp any any eq 2428
 permit tcp any any range 2000 2002
 permit udp any any eq 1719
 permit udp any any eq 5060
ip access-list extended AutoQoS-VoIP-RTCP
 permit udp any any range 16384 32767
!
logging trap debugging
logging facility local1
logging x.x.x.x
access-list 12 permit x.x.x.x
access-list 12 permit x.x.x.x
!
!
snmp-server group admins v3 auth read adminview write adminview
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
!
voice-port 0/0/0
 trunk-group 1
 input gain 6
 output attenuation 2
 connection plar 1398
!
voice-port 0/0/1
 trunk-group 1
 input gain 6
 output attenuation 2
 connection plar 1398
!
voice-port 0/0/2
 trunk-group 1
 input gain 6
 output attenuation 2
 connection plar 1398
!
voice-port 0/0/3
 trunk-group 1
 input gain 6
 output attenuation 2
 connection plar 1398
!
!
!
mgcp profile default
!
!
dial-peer cor custom
!
!
dial-peer voice 10 pots
 trunkgroup 1
 tone ringback alert-no-PI
 destination-pattern 6[2-9]......
 progress_ind setup enable 3
 progress_ind alert enable 8
 forward-digits 7
!
dial-peer voice 20 pots
 trunkgroup 1
 tone ringback alert-no-PI
 destination-pattern 61[2-9].........
 progress_ind setup enable 3
 progress_ind alert enable 8
 forward-digits 11
!
dial-peer voice 30 voip
 preference 2
 destination-pattern 1[2-6]..
 progress_ind setup enable 3
 session target ipv4:x.x.x.x
 incoming called-number .
 voice-class codec 1  
 voice-class h323 1
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 40 voip
 preference 1
 destination-pattern 1[2-6]..
 progress_ind setup enable 3
 progress_ind alert enable 8
 session target ipv4:x.x.x.x
 incoming called-number .
 voice-class codec 1  
 voice-class h323 1
 dtmf-relay h245-alphanumeric
 no vad  
!
dial-peer voice 911 pots
 trunkgroup 1
 tone ringback alert-no-PI
 destination-pattern 6911
 progress_ind setup enable 3
 progress_ind alert enable 8
 forward-digits 3
!
dial-peer voice 912 pots
 trunkgroup 1
 tone ringback alert-no-PI
 destination-pattern 911
 progress_ind setup enable 3
 progress_ind alert enable 8
 forward-digits 3
 prefix 6
!
!
!
!
gatekeeper
 shutdown
!
!
credentials
!
!
call-manager-fallback
 max-conferences 8 gain -6
 transfer-system full-consult
 ip source-address x.x.x.x port 2000
 max-ephones 24
 max-dn 48
!
!
banner motd ^CCC For use by Authorized Altoona First Savings Bank Only. UNAUTHORIZED ACCESS TO THIS NETWORK DEVICE IS PROHIBITED. You must have explicit permission to access or configure this device. ^C
!
line con 0
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 login local
 transport input ssh
line vty 5 15
 privilege level 15
 login local
 transport input ssh
!
scheduler allocate 20000 1000
end



The Gateways on my Call Manager are H323 and I have reset those.
0
 
LVL 20

Expert Comment

by:agonza07
ID: 37783031
Config looks good as far as I can tell.

Do a "show voice port sum" and you should see which ports are off-hook or on-hook. It could be there are too many calls going on, and maybe that's why you are getting the fast busy. You could also have some lines that may not be working as well...

It may be time to start debugging these and find out why you are getting the fast busy. Do a "term mon" and then a "debug voice dialpeer all" then have someone at that office start making calls until you get the fast busy and send over the debug. Might be best to attach it as a txt file this time. Make sure that once they get the fast busy to do the "show voice port sum" to check if maybe all the lines are busy.
0
 

Author Comment

by:Doug_Ickes
ID: 37783838
I grabbed a debug from one of my branch routers. All of the branches (5 of them) are experiencing the same issue. Some calls go through when you pick up the phone and dial and others you get a fast busy as soon as you dial. It is intermittant.
Debug.txt
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 20

Expert Comment

by:agonza07
ID: 37783990
All your dial peers are matching up fine.

I'm more familiar with ISDN than FXO's but also run this debug and post your findings.

debug voice ccapi inout

During the debug that you posted, did people get the fast busy? If the ccapi debug shows everything is going good, then the problem will point to something on the call manager side. I'll wait for the debug output.
0
 

Author Comment

by:Doug_Ickes
ID: 37784040
First of all I want to say "Thanks" for your assistance and persistence!

Secondly, the last debug and this one both had fast busy symptoms in the debug. I am going to reboot the Call Manager tonight to see if that resolves my issue. I replaced all of the branch routers(5 of them) this week and that is when the problems started.
Debug2.txt
0
 
LVL 20

Accepted Solution

by:
agonza07 earned 500 total points
ID: 37784138
No problem.

Make sure to do an "undebug all" after you finish debugging because it takes a lot of CPU cycles when you have debugging turned on.

Go ahead and reboot the Call Manager tonight and report back tomorrow.

I see at the very end there are some call disconnect codes
Cause Value=34
http://www.cisco.com/en/US/docs/ios/12_3/vvf_c/voice_troubleshooting/old/vts_appa.html

But that one means there are no circuits available. So it could just mean that the FXO's didnt disconnect immediately during the testing and ended up filling up and caused that fast busy in the end of that debug.

If the reboot doesn't fix things tomorrow, one thing to check is how long it takes for those FXO ports to release the call after you hang up using the "show voice port sum" command.
0
 

Author Comment

by:Doug_Ickes
ID: 37796252
I was out of the office on Friday but I was able to reboot our Call Manager after hours and that did not resolve my issue.

I worked with one branch and ran the "show voice port sum" command with them making several phone calls. What I did notice is that I have a 4 port voice card in my routers but only have 2 or 3 lines connected to each. I found that the voice card was trying to use each port in order even if there was no line present. I shutdown the ports that are not being used and that resolved my issue.

I appreciate you diligence and I am awarding you all of the points. Thanks again for your assistance!
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now