Enable the Welcome Screen login in XP Pro when using NComputing vSpace

I am using NComputing x350 and vSpace 4.04.010 on an XP Pro PC.  Ordinarily when you install vSpace it sets XP up for multi user login… Meaning you get the username and password login box rather than the welcome screen with the various user icons.  I think this has something to do with fast user switching.
Normally this is fine but I am setting this up for a kindergarten classroom and I would sure love to “Change the way user’s login” and utilize the Welcome screen.  When I do this I get a “Windows cannot apply the welcome screen setting you selected” error message.  If I try to disable fast user switching I get “Windows cannot apply the Fast User Switching setting you selected”.
I am sure this is an NComputing issue (their tech support was not much help) but there must be a Registry or Group Policy setting to force the setting.
Having kindergartener’s login with a username is asking for trouble… If they could go up to one of the NComputing stations (Host or Stations) and just press their user icon will make it a much more successful experience for the kids (and the teachers)
mjobesAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dav GrayIT ManagerCommented:
Hi,

You could try the following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\Current Version\WinLogon

Change the value for LogonType, from a "1" to a "0". This is because a 0 specifies Classic Mode and a 1 specifies Welcome Screen.

Now, exit the Registry and Reboot your computer.

Remember to always have a recent back up of your registry before attempting to make changes.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Vanguard_LHCommented:
When you configure your host to participate in a domain (instead of a workgroup), you lose the Fisher-Price bobblehead "Welcome Screen" for login.  In a domain, you get the classic login dialog.  In a workgroup, by default, you get the Welcome Screen (but can change to the classic login screen using a policy which is just a registry entry).

Read http://support.microsoft.com/kb/303594.  Check if your host is in a workgroup or in a domain.  In a domain, there's no Welcome Screen available.  You could try to reenable the Welcome Screen.  If it's greyed out, I'm guessing you're in a domain.

The vSpace client recommends Pro versions of Windows for the client.  They also require server versions of Windows (if you're just in a Windows environment; i.e., no Linux servers).  So it looks like the setup requires a client-server relationship and probably requires a domain operated by the server to validate the workstations that connect to it.

Some networking software won't let you use the Welcome Screen and force you back to the classic login screen.  For example, read http://support.microsoft.com/kb/315347.  So if your host isn't in a domain (so that's not the reason for getting moved to the classic login dialog), it could be the vSpace Client program.  You could uninstall it and check if you can enabled and get the Welcome Screen (and can also enable Fast User Switching) or if you're still stuck with the classic login screen).
mjobesAuthor Commented:
I tried setting HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\Current Version\WinLogon – LogonType to “1” (I am trying to enable welcome screen)… I get the following error:
 “Cannot edit LoginType: Error writing the  value’s new content”.
Googleing  this suggested I take ownership of the registry key.  When trying to take ownership on the Key and its subkeys I get the following message:
“Registry Editor could not set owner on the key currently selected or some of its subkeys.”

I am using XP Pro on a workgroup PC (not in a domain).  I tried uninstalling vSpace… Setting login to the Welcome Screen (worked ok)… Then reinstalling vSpace…  When vSpace was reinstalled we were back to the classic login screen.  
I have a feeling I am SOL but I sure would like to have the “Fisher-Price bobblehead Welcome Screen for login”… Any more ideas out there?
mjobesAuthor Commented:
Ok... I believe I have it now. I was able to make the registry edit by booting up the PC in safe mode.

Now I have the “Fisher-Price bobblehead Welcome Screen for login” on both the Host PC and the virtual client stations.

(I like the Fisher-Price bobblehead reference... if you don't mind I am going to steal it) : )
mjobesAuthor Commented:
Guyver-it, Vanguard_LH and myself all had a hand in figuring this out...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.