[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Can't open Outlook using Outlook 2010 Exchange 2010

Posted on 2012-03-28
20
Medium Priority
?
1,417 Views
Last Modified: 2012-04-03
I have an Exchange Server 2010 running on a Windows Server 2008 R2 in a test environment. It's up, and running without incident. I have a laptop running Vista Business on which I installed Office Professional 2010. When I open Outlook to configure the Exchange mail account on the server, it finds the account and sets it up in Outlook with no problems.

Here is where the problem comes in. When I open Outlook, I get the following error evry time:

'Cannot open your default email folders. You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your Outlook data file (.ost).'

I have been all over the internet, and tried just about everything that was suggested (deleted the .ost, deleted the profile, etc., just to name 2 of about a dozen suggestions I found out there) and nothing has worked.

I'm at my wits end over this, so I'm hoping somebody can shine some new light on the issue for me. It would be very much appreciated.
0
Comment
Question by:patkengroup
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 5
  • 3
  • +1
20 Comments
 
LVL 3

Expert Comment

by:y4utech
ID: 37779677
Check the status of "Microsoft Exchange RPC Client Access" service on the server. It must in "Running" state. If that service is in running state then just restart it once & recheck the status of Outlook.
0
 

Author Comment

by:patkengroup
ID: 37779692
It was running. I stopped it, then restarted it. Tried to open Outlook on the client, but I got the same error.
0
 
LVL 3

Expert Comment

by:y4utech
ID: 37779784
Check the "EncryptionRequired" on server by using following command

Get-RpcClientAccess | fl

If it is True then enable the "Encrypt data between Microsoft Office Outlook and Microsoft Exchange" in user outlook profile setting.

To manually update an existing Outlook 2010 profile so that it uses RPC encryption with Exchange 2010, follow these steps:
1. In Control Panel, open the Mail item.

2. Click Show Profiles.

3. Select your profile, and then click Properties.

4. Click E-mail Accounts.

5. Select the Microsoft Exchange Server account, and then click Change.

6. In the dialog box that contains your mailbox server and user name, click More Settings.

7. In the Microsoft Exchange dialog box, click the Security tab.

8. Click to select the Encrypt data between Microsoft Office Outlook and Microsoft Exchange check box, and then click OK.

http://www.chicagotech.net/exchange/outlookerror2.htm
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 47

Expert Comment

by:apache09
ID: 37779821
Check that Office 2010 SP1 is installed:
http://support.microsoft.com/kb/2460049

then test

I would also go into Control Panel
Open Up Mail Option
Open the User account that has been setup
Under exchange server Name
Remove the tick next to Use cached Exchang mode

APply, CLose

Now try again
0
 

Author Comment

by:patkengroup
ID: 37780075
y4utech: I couldn't get the "Get-RpcClientAccess | fl' to run at the command prompt on the Exchange server. I got a 'command not recognized error. I do know that the Outlook 2010 client is set for encrypted data. That was one of the dozen or so solutions I found out on the 'net, which were not successful in solving the problem.
0
 

Author Comment

by:patkengroup
ID: 37780084
apache09: I'm downloading the Office 2010 SP1 now, and will install it to see if it helps. However, I tried removing the tick for cached Exchange mode (that was also in the dozen solutions on the net), but it did not fix my problem.
0
 
LVL 3

Expert Comment

by:Padamdeep
ID: 37780260
1. Go to your Outlook Account Settings and look at the Mailbox Name. It is going to be your CAS Server OR CAS Array Name.
2. Are you able to ping this CAS Server or CAS Array name from the client Machine?
3. Are you trying to configure profile Internal to the network or from outside?
4. Is Microsoft Exchange Address Book Service running on CAS Server or not?

Please check these things and let me know the results

~ Singh
0
 

Author Comment

by:patkengroup
ID: 37781128
1. I assume the FQDN of 'mail.domain_name.local' is the CAS Server? If so, that is the server the Outlook account is pointing to. During setup, it finds the mail account I'm trying to set up instantly, with no issues
2. Yes, if 1. above is true
3. Internal profile
4. Yes
0
 
LVL 3

Expert Comment

by:Padamdeep
ID: 37781833
Please don't assume Step # 1 and 2. I would suggest you to verify it by going to Outlook Profile and then run the Ping command to verify it.

That's the first step. Without 100% sure we can't proceed.

~Singh
0
 
LVL 3

Expert Comment

by:y4utech
ID: 37783190
Locate the Outlook icon in SysTray, then hold down the Ctrl key and right-click it for the extended menu -- you will see that Test Outlook AutoConfiguration is an option. Just check the same once from Client PC.
0
 

Author Comment

by:patkengroup
ID: 37783395
Padamdeep: Sorry for the language confusion. I didn't assume that it was pointing to the server, or that I could ping it. The Outlook client is pointing to the Exchange server, and I can ping it. I verified that before i responded to you.

What I 'assumed' was that you meant the 'CAS Server' was the sames as the Exchange Server/Domain Controller server. My Exchange server ('mail.domain_name.local') is also the DC.

I hope that adds more clarity to my answers.

After all that , it still doesn't connect.
0
 

Author Comment

by:patkengroup
ID: 37783573
Y4Utech: I am away from that machine today. I will try your suggestion when i get back to it tonight, and let you know the results.
0
 

Author Comment

by:patkengroup
ID: 37785175
Y4utech: Outlook 2010 doesn't appear in the Vista Business systray. Doesn't it have to start before it will appear there? I can't even get it to start once.
0
 

Accepted Solution

by:
patkengroup earned 0 total points
ID: 37785243
To all who contributed to this issue: I found my answer! It is contained in this article:

http://blog.mpecsinc.ca/2011/06/outlook-error-cannot-open-your-default.html

Thanks again for all the contributions. The Outlook client is now open and running smoothly!
0
 
LVL 3

Expert Comment

by:Padamdeep
ID: 37785436
What you have found is not a solution but a Work Around.

32 MAPI sessions are more than enough. If you have run out of 32 sessions you may run out of 128 sessions as well but that may take couple of days/Weeks.

There is a network device between your Exchange Server and Client which is silently dropping the connection without notifying Exchange Server and Client and hence orphan connection still persist.

You need to increase the TcpKeepAlive on that Network Device to more than 2 hours.

~ Singh
0
 

Author Comment

by:patkengroup
ID: 37785475
Interesting. Thank you for that 'heads up'. Since it is a test environment, I will let it run for a at least a week and see if what you have said happens.

I'll report back
0
 
LVL 3

Expert Comment

by:Padamdeep
ID: 37785481
If you really want to test it then keep the settings as default 32 sessions and see if it runs out again.

~ Singh
0
 

Author Comment

by:patkengroup
ID: 37786524
will do, and i will let you know what happens.

There is reason to believe that both of you are right, that the fix I put in from that article I referenced above may have fixed the problem as a coincidence. In addition to the registry entry, I also re-started the Information Store. I had never done that before in any of the troubleshooting steps. It could be that the IS was the problem all along, and that a simple re-start fixed my problem.
0
 
LVL 3

Expert Comment

by:Padamdeep
ID: 37787822
That's right. Once you restart the Information Store, it is going to Reset the connection and the count starts from 1 again.

~ Singh
0
 

Author Closing Comment

by:patkengroup
ID: 37800063
While waiting for responses at EE, I continued to search for an answer using Google. That is where I stumbled across the solution for me!
0

Featured Post

Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

By default Outlook 2016 displays only one time zone in the Calendar. The following article explains how to display two time zones in one calendar view.
As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question