Exchange 2010 Autodiscovery url wrong on external use

Hello.
I have a wierd problem with my Exchange setup.

It started with users having problem using the Out Of Office function in outlook. I could use it without problem when located inside the domain but external users cant!

When I check the Autodiscovery url from an internal account (inside the domain) it shows up correct;
https://mail.domain.com/autodiscover/autodiscover.xml

But when I check Test email AutoConfiguration from an external outlook it gives me
https://domain.com/autodiscover/autodiscover.xml

PS gives me this :
[PS] C:\Windows\system32>Get-ClientAccessServer | Select Name, *Internal* | fl


Name                           : EMAIL
AutoDiscoverServiceInternalUri : https://mail.domain.com/autodiscover/autodiscover.xml

Open in new window


Anyone got a suggestion?
LVL 3
tigerffsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tigerffsAuthor Commented:
Also, when I check the external URL in PS it gives me
[PS] C:\Windows\system32>get-webservicesvirtualdirectory | FL ExternalURL


ExternalUrl : https://OLDSERVER.domain.com/ews/exchange.asmx

Open in new window


It is pointing to the old exchange 2003 server, could this be the issue?


EDIT: I did set the externalURL to the correct one, it does not help me with the AutoDiscovery though
0
MAS (MVE)EE Solution GuideCommented:
Try creating an A record 'autodiscover.domain.com' in your external DNS poiting to your external exchange IP
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MAS (MVE)EE Solution GuideCommented:
Change the external URL to

ExternalUrl : https://externalname.domain.com/ews/exchange.asmx
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

tigerffsAuthor Commented:
Really I just want to change the URL for autodiscovery for external use of outlook, pointing a fault adress seems like an shortcut.
0
tigerffsAuthor Commented:
abbasiftt:
I did that but it had no impact on the problem :(
0
tigerffsAuthor Commented:
Where does outlook get this AutoDiscovery link from? I need to be able to change it somewhere, but where!? For internal use = OK
External use = NOK
0
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
Create an "A" record in your public DNS called autodiscover and point it to your firewall with public IP. Get the firewall to forward 443 port traffic to this IP to your CAS server.

There is no setting for this. Outlook looks up the autodiscover record in the email domain of yours. So, if your email is user@domain.com, Outlook checks to find https://autodiscover.domain.com/autodiscover/autodiscover.xml

All you need to do is setup record in public DNS and route it to CAS.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.