Outlook Web App working on internal network but not from an external network


I'm setting up an Exchange 2010 infrastructure, and am in the lucky situation of having four Exchange servers.  My company has a single domain and one site.  Two of the servers are running the Client Access Server and Hub Transport roles, and the other two servers are running the Mailbox roles and a DAG.  I'm using Windows Network Load Balancing on the first two servers and a CAS array.  Connecting to https://mail.domain name/owa works fine internally, but I can't get it to work when connecting from an external network - the OWA login page won't display.  I've checked the firewall settings, and been in touch with the firewall provider who has confirmed that the packets are correctly being forwarded to the CAS array.

Can anyone help?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

WORKS2011Austin Tech CompanyCommented:
check FBA (Form Based Authentication) in exchange, open EMC | Server Configuration | Client Access | Outlook Web Access | Authentication | Logon Format.

Do you have SBS or Server environment, IIS will be different in each. Either way if the above doesn't get the logon screen to show we'll move into IIS.
vphulAuthor Commented:
Hello Works2011,

The authentication for Outlook Web App is set to Use forms-based authentication, and Logon format is domain\username.

The servers are running Windows 2008 R2.
WORKS2011Austin Tech CompanyCommented:
what error do you get from your browser, is it access denied? Please show screen shot or provide info.
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

vphulAuthor Commented:
I get Internet Explorer cannot display the webpage.
WORKS2011Austin Tech CompanyCommented:
have you got all the updates for IE, cleared cache and tried another computer with IE. Could reset as well. Usually if the problem is with IIS you get an HTTP error, doesn't sound like IIS is kicking back the request sounds more like IE not resolving.

None of the errors show up on this page.
vphulAuthor Commented:
I've tried it on my Android smartphone, and it doesn't work on that either when using different wireless networks. There are no error numbers in IE at all.
vphulAuthor Commented:
I've also tried another laptop, and Google Chrome, and still no luck. :-(
WORKS2011Austin Tech CompanyCommented:
I had an error like this and the problem was with the firewall, IIS errors are often reported with an access denied / http error meaning the content is passed through to IIS, I'm not confident all the data is getting to IIS. As well without the firewall (internal) it's working fine.
vphulAuthor Commented:
Thanks Works2011 for all your advice.  We have Watchguard firewalls, and I'm going to contact Watchguard again about this matter.
vphulAuthor Commented:
Watchguard advised me to run Wireshark on the CAS array servers.  It seems that https traffic from an external network is reaching them, but not being acknowledged.  Please see screenshots of data captured when accessing https://mail.domainname/owa internally and externally.
vphulAuthor Commented:
I'm pleased to report that this matter has been resolved.

I am using NLB in unicast mode and discovered that you have to enable IP forwarding on the NLB LAN nic on each server.

IP forwarding should be enabled on each cluster member’s NLB LAN NIC.  By default, Windows 2008/2008 R2 disables IP forwarding, which causes problems with NLB.  IP forwarding enabled allows, from an NLB perspective, requests sent from one NIC to be sent out the other.  IP forwarding can be enabled on your NLB LAN NIC by running

netsh interface ipv4 set interface “NLB LAN” forwarding=enabled

 from a command prompt.

Many thanks to


for the information.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vphulAuthor Commented:
By doing lots of research myself, I found the solution.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.