Solved

Column 'OwnerGroup' does not belong to table Table.

Posted on 2012-03-29
18
863 Views
Last Modified: 2012-04-02
I am getting error when i call the following function:


Dim DataXmlId As Guid = Guid.NewGuid
            TPStyleDevelopmentInsert(DataXmlId.ToString, StyleId, strStyleColorwaySeasonYearID, strSystemCultureId)
            Response.Redirect(strReportServer & "/TPFolderRedirect.aspx?DXID=" & DataXmlId.ToString & "&SDID=" & _StyleDevelopmentId & "&SID=" & StyleId & _
                              "&RTPID=" & ReportTPFolderId & "&SV=" & Request.QueryString("SV") & "&SSID=" & Me._StyleSourcingID & _
                              "&TID=" & Me.UserProperties.TeamID & "&SYID=" & Me._SeasonYearID & "&SN=" & Me._StyleSet)

Open in new window



And error is :

Error:Column 'OwnerGroup' does not belong to table Table.

Page:/almReport/TPFolderRedirect.aspx?
DXID=1a79a78b-30bc-4b35-a7b9-85381fe0988e&SDID=6dac0929-4e19-4ef1-acfc-3a367ce89eb0
&SID=dab0f156-06a8-450a-8df8-1285ab8fafee&RTPID=f1000000-0000-0000-0000-000000000010&SV=2
&SSID=3f47ed6f-584b-4cae-9ec6-6462f19d80d2
&TID=203517c2-2bd4-4ed3-9ef7-ac37de447321
&SYID=60f5b984-9def-4cb4-af17-387e2719f28b&SN=1
Exeption:System.ArgumentException

System.Data
Trace: at System.Data.DataRow.GetDataColumn(String columnName) at System.Data.DataRow.get_Item(String columnName) 
at almCore.FormHandler.GetReportSqlControls() 
at alm2Report.TPFolderRedirect.LoadXMLFile(Object XmlId) 
in D:\Jais\JaisPLM\Trunk\Software\padawan\Application\alm2Report\TPFolderRedirect.aspx.vb:line 339 
at alm2Report.TPFolderRedirect.GetSqlReport() 
in D:\Jais\JaisPLM\Trunk\Software\padawan\Application\alm2Report\TPFolderRedirect.aspx.vb:line 658 
at alm2Report.TPFolderRedirect.Page_Load(Object sender, EventArgs e) 
in D:\Jais\JaisPLM\Trunk\Software\padawan\Application\alm2Report\TPFolderRedirect.aspx.vb:line 155 
at System.Web.UI.Control.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() 
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, 
Boolean includeStagesAfterAsyncPoint)

Open in new window


What is the cause of this ?
0
Comment
Question by:PeteEngineer
  • 12
  • 6
18 Comments
 
LVL 44

Accepted Solution

by:
AndyAinscow earned 500 total points
ID: 37781563
According to the error message you are requesting the value in a field called OwnerGroup from a table (data set) - but that doesn't appear in your code snippet.
Can you step into the function and see where this field is being requested ?
0
 
LVL 8

Author Comment

by:PeteEngineer
ID: 37781585
which function i need to step into ?

alm2Report.TPFolderRedirect.LoadXMLFile(Object XmlId)
alm2Report.TPFolderRedirect.GetSqlReport()
at alm2Report.TPFolderRedirect.Page_Load(Object sender, EventArgs e)
0
 
LVL 44

Expert Comment

by:AndyAinscow
ID: 37781602
I don't know -  I don't see the code they contain.
Just step into the function then out again - if it errors then you know it is somewhere in that particualr function.
0
 
LVL 8

Author Comment

by:PeteEngineer
ID: 37781629
I will put a break point on the first line of all the above three functions

let me see
0
 
LVL 8

Author Comment

by:PeteEngineer
ID: 37781650
I am not able to hit the break point when the execution reaches the following line:

Response.Redirect(strReportServer & "/TPFolderRedirect.aspx?DXID=" & DataXmlId.ToString & "&SDID=" & _StyleDevelopmentId & "&SID=" & StyleId & _
                              "&RTPID=" & ReportTPFolderId & "&SV=" & Request.QueryString("SV") & "&SSID=" & Me._StyleSourcingID & _
                              "&TID=" & Me.UserProperties.TeamID & "&SYID=" & Me._SeasonYearID & "&SN=" & Me._StyleSet)
           

it shows the error which i posted above.
0
 
LVL 8

Author Comment

by:PeteEngineer
ID: 37781706
ok..i am passing a false as a parameter and try
0
 
LVL 8

Author Comment

by:PeteEngineer
ID: 37781784
that not working ..i am unable to hit the break points to see whats happening!
0
 
LVL 44

Expert Comment

by:AndyAinscow
ID: 37781841
OK.
Looking at the trace stack
line 14:  at alm2Report.TPFolderRedirect.LoadXMLFile(Object XmlId)
Maybe check that first.

You could also do a search for the string 'OwnerGroup' - that is what the exception refers to.
0
 
LVL 8

Author Comment

by:PeteEngineer
ID: 37781861
Ok let see the possibiliteis of problem area as bellow :

I found page load call getsqlreport and this calls loadxml

and there is a line may cousing the issue shown below :

        ReportTableInsert(conConnection, XmlId, objXmlHandler.DataColumnNumber, objXmlHandler.DataColumn, objXmlHandler.DataHeader, objXmlHandler.DataValue, i)
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 
LVL 8

Author Comment

by:PeteEngineer
ID: 37782003
i have searched there is no ownergroup anyway
0
 
LVL 8

Author Comment

by:PeteEngineer
ID: 37782015
I got a defenition of function above :


 Private Shared Sub ReportTableInsert(ByVal connection As SqlConnection, ByVal dataXmlId As String, ByVal dataColumnNumber As Integer, _
        ByVal dataColumnName As String, ByVal dataHeader As String, ByVal dataValue As String, ByVal dataSort As String)

        Dim spx As String = plmOnCore.SPXoverride.GetSPX_Shared(connection, "TechPackFolderRedirect", "spx_RptTable_INSERT")
        Dim params() As SqlParameter = { _
            New SqlParameter("@DataXmlID", SqlDbType.VarChar, 40, ParameterDirection.Input, False, Nothing, Nothing, Nothing, DataRowVersion.Current, dataXmlId), _
            New SqlParameter("@DataColumnNumber", SqlDbType.Int, 4, ParameterDirection.Input, False, Nothing, Nothing, Nothing, DataRowVersion.Current, dataColumnNumber), _
            New SqlParameter("@DataColumnName", SqlDbType.NVarChar, 200, ParameterDirection.Input, False, Nothing, Nothing, Nothing, DataRowVersion.Current, dataColumnName), _
            New SqlParameter("@DataHeader", SqlDbType.NVarChar, 200, ParameterDirection.Input, False, Nothing, Nothing, Nothing, DataRowVersion.Current, dataHeader), _
            New SqlParameter("@DataValue", SqlDbType.NVarChar, 4000, ParameterDirection.Input, False, Nothing, Nothing, Nothing, DataRowVersion.Current, dataValue), _
            New SqlParameter("@DataSort", SqlDbType.VarChar, 5, ParameterDirection.Input, False, Nothing, Nothing, Nothing, DataRowVersion.Current, dataSort) _
        }
        SqlHelper.ExecuteNonQuery(connection, CommandType.StoredProcedure, spx, params)

    End Sub

Open in new window



Looks like problem is from @DataColumnName"

what say?
0
 
LVL 44

Expert Comment

by:AndyAinscow
ID: 37782017
Have you checked the values of the different objects contained within objXmlHandler ?  One of those might be 'OwnerGroup'
0
 
LVL 8

Author Comment

by:PeteEngineer
ID: 37782030
how can i check i cannot hit the breakpoint ..i can use sql profiler but still no use
0
 
LVL 44

Expert Comment

by:AndyAinscow
ID: 37782061
aaaargh !!!

Can you check it when it gets filled ?
0
 
LVL 8

Author Comment

by:PeteEngineer
ID: 37782073
when it filled in means? i didnt get?
0
 
LVL 44

Expert Comment

by:AndyAinscow
ID: 37782317
Somewhere you load the contents of that object - from file / database / ...
Check at that point if there is an 'OwnerGroup'
0
 
LVL 8

Author Comment

by:PeteEngineer
ID: 37786435
Just see the files ... and am still not getting where actually causing the error
Pageload
GetSQLReport
LoadXML
0
 
LVL 8

Author Comment

by:PeteEngineer
ID: 37786438
The above files are from the page which is redirected

and button click event of the page has the redirect code which i pasted above.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

More often than not, we developers are confronted with a need: a need to make some kind of magic happen via code. Whether it is for a client, for the boss, or for our own personal projects, the need must be satisfied. Most of the time, the Framework…
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Many functions in Excel can make decisions. The most simple of these is the IF function: it returns a value depending on whether a condition you describe is true or false. Once you get the hang of using the IF function, you will find it easier to us…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now