Solved

Cisco ASA 5505 and no internet access help

Posted on 2012-03-29
4
501 Views
Last Modified: 2012-08-13
Hello,

We are currently having issues implementing a new Cisco ASA 5505 into our network and are replacing an older Sonicwall. We currently have a SBS 2003 server and a Sonicwall VPN Firewall that houses DHCP (yes, the old IT guy put DHCP on the Sonicwall and not the SBS for some reason).

Anyways, the company manager wants the same setup with the new Cisco ASA as the old Sonicwall for the time being, until we get the new SBS 2011 server running. In other words, they want the Cisco ASA running DHCP, as well as the normal VPN/Firewall setup. I tried configuring it using the ASDM; however am having issues with client computers getting internet access. What's weird is that they are able to get IP's via DHCP and only the SBS server is able to get internet access (due to static IP maybe?) for some reason. Below is the running config and any help via ASDM would be greatly appreciated:


ASA Version 8.4(2)
!
hostname asa
enable password none. encrypted
passwd none encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 205.x.x.240 255.255.255.0
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 24.x.x.35
 name-server 24.x.x.36
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network SBS_2003
 host 192.168.2.49
object network NETWORK_OBJ_192.168.2.0_24
 subnet 192.168.2.0 255.255.255.0
object network NETWORK_OBJ_192.168.5.192_27
 subnet 192.168.5.192 255.255.255.224
access-list outside_access_in extended permit tcp any interface outside eq smtp
access-list outside_access_in extended permit tcp any interface outside eq https
access-list outside_access_in extended permit icmp any interface outside
access-list name_splitTunnelAcl standard permit 192.168.2.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPN_Users 192.168.5.194-192.168.5.220 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
nat (inside,outside) source static NETWORK_OBJ_192.168.2.0_24 NETWORK_OBJ_192.168.2.0_24 destination static NETWORK_OBJ_192.168.5.192_27 NETWORK_OBJ_192.168.5.192_27 no-proxy-arp route-lookup
!
object network obj_any
 nat (inside,outside) dynamic interface
object network SBS_2003
 nat (inside,outside) static interface service tcp smtp smtp
!
nat (inside,outside) after-auto source dynamic any interface
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 205.x.x.239 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.2.0 255.255.255.0 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ikev1 enable outside
crypto ikev1 policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet 192.168.2.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0

dhcpd address 192.168.2.160-192.168.2.199 inside
dhcpd dns 192.168.2.49 24.29.99.36 interface inside
dhcpd wins 192.168.2.49 24.29.99.36 interface inside
dhcpd domain name interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy name internal
group-policy name attributes
 wins-server value 192.168.2.49
 dns-server value 192.168.2.49
 vpn-tunnel-protocol ikev1
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value name_splitTunnelAcl
 default-domain value name.local
username ben password zWCAaitV3CB.GA87 encrypted privilege 0
username ben attributes
 vpn-group-policy name
username joe password O72LiZyIktgAjNrI encrypted privilege 0
username joe attributes
 vpn-group-policy name
tunnel-group name type remote-access
tunnel-group name general-attributes
 address-pool VPN_Users
 default-group-policy name
tunnel-group name ipsec-attributes
 ikev1 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:620e61ec5a64f9c3bdbcd70da69f53b6
: end
no asdm history enable
0
Comment
Question by:DDI4U
  • 2
  • 2
4 Comments
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 37782109
Anything showing in the logs when trying to get to the internet?
0
 

Author Comment

by:DDI4U
ID: 37782769
Unfortunately I wasn't able to get a copy of the logs before I left work yesterday and will not be back in the office till next week.

Does the running config file look good to you however?  Anything I should possibly change to fix the no internet / traffic outside problem?  I essentially just took the IP information I saw from the Sonicwall and configured it to the Cisco ASA.  I was thinking I might have messed up on the static route  or external gateway config somehow, since it's a different setup than Sonicwall, but not sure.
0
 
LVL 35

Accepted Solution

by:
Ernie Beek earned 500 total points
ID: 37786007
As far as I can see it looks ok (but I'm still trying to get used to the +8.3 syntax ;)

I took the liberty of adding the "Cisco PIX Firewall" topic to your question to see if we can get some more assistance from my fellow experts.
0
 

Author Closing Comment

by:DDI4U
ID: 37787820
Thanks, no need to dig any further on this.
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

Network traffic routing plays key role in your network, if you have single site with heavy browsing or multiple sites, replicating important application data from your Primary Default Gateway ,you have to route your other network traffic from your p…
This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
This video discusses moving either the default database or any database to a new volume.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now