Set up default program type in Windows 7 for Office Excel

So whenever I try to open up an .xlsx file It opens in some other program in Excel. I go into the program defaults and change the type. However in this document I dont even see the Excel program listed. http://windows.microsoft.com/en-US/windows-vista/Change-which-programs-Windows-uses-by-default

I also right clicked the file and went to open with. I tried to select the Excel.exe under the office 14 folder but after selection nothing changed.
cmdolcetAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
JohnConnect With a Mentor Business Consultant (Owner)Commented:
If you ran System File Checker and then also since you re-installed Office, there must be something wrong with your Windows 7 setup.

If you have the Windows 7 DVD, you can do a repair install (back up first). Otherwise, you may have to re-install Windows 7 at a convenient time. .... Thinkpads_User
0
 
JohnBusiness Consultant (Owner)Commented:
Open Default Programs, Select .xlsx and double click. In the window that comes up, there is a little plus sign. Can you expand that and see Excel?

Excel-Defaults
... Thinkpads_User
0
 
Run5kCommented:
To add on to Thinkpads' good advice, it may be a good idea to follow the instructions on this page and utilize the link found on the subsequent list to restore the default EXE file association:

Restore Default Windows 7 File Extension Type Associations
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
cmdolcetAuthor Commented:
thinkpads_user, I tried your advice and when I get to the window with (+) sign I can't see the Microsoft option available. So I go to browse and go into the Office 14 folder and select the Excel.exe file and nothing seems to change.
0
 
JohnBusiness Consultant (Owner)Commented:
Since the default behaviour won't work here, there appears to be something wrong with the operating system.

Try running System File Checker:   In an admin command window, run SFC /SCANNOW and allow to complete. Restart. Run again if it said there were errrors.

Repairs after SFC are more aggressive so please let us know to this point.

.... Thinkpads_User
0
 
Run5kCommented:
Not to belabor the point, but did you already try resetting your default EXE file associations?
0
 
cmdolcetAuthor Commented:
OK a little more feedback, I can;t see to change anything in the user profile that relates to excel. I can switch the default program extension to Word or PowerPoint however Excel does not want to take. So I decided to reinstall the whole office suite. Now I have my excel program without any toolbar and I still can;t change the .xlsx over to Excel.
0
 
JohnBusiness Consultant (Owner)Commented:
Thank you, and I was pleased to help you with this. ... Thinkpads_User
0
 
Run5kCommented:
Well Cmdolcet, it was nice chatting with you!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.