• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 742
  • Last Modified:

Old BlackBerry Storm 2 with no cell provider - How do i get this to use wifi to connect to the internet?

I have an old BlackBerry Storm 2 that I want to use for general web browsing. This smartphone has no cellular provider - it is just a decommissioned phone for which I would like try to get web browsing to work over WiFi. Connecting to WiFi is no problem - it is just getting browsing to actually default to and use WiFi.

I don't care if I have to wipe this phone to get it to work.  Or installing alternate browsers to get this to work would be fine, so long as the install can happen over USB.

What I have done:
Connected the phone to my WiFi network.
Options > Advanced Options > TCP/IP: Unchecked and cleared all APN values
Options > Advanced Options > Browser: Changed default browser configuration to Hotspot Browser.
Browser > Options > Browser Configuration: Set browser to Hotspot Browser.

The upper-right corner is showing a WiFi icon, no cellular icons.  When making an initial request for a web page, there is the brief appearance of the <--> icon showing data transfer.

With these settings, when I am in browser and I try to go to a site, such as Google, after a long timeout I get this message:
"Unable to connect to the selected Mobile Data Service, please try again later.  If the problem persists please contact your administrator."

Ultimately I want to get this to work with Pandora, but I will use it for other web usage as well.
0
HomerTNachoCheese
Asked:
HomerTNachoCheese
  • 5
  • 4
2 Solutions
 
Raymond PengSystems EngineerCommented:
I don't have a storm on me but on my BB > Under options > Mobile Network (u might be able to just universal search on your device for it) > Data Services > select on

Connection preferences > Wifi Only.
0
 
HomerTNachoCheeseAuthor Commented:
l33tf0b:  On the Storm 2, in Options > Mobile Network I have:

Data Services = On
While Roaming = On (other options are off and prompt)
Mobile Network = *None* (cannot change this on this screen)
Network Selection Mode = Automatic (no other options available)
Network Technology = Global (other options are GSM/UMTS, 1XEV)

There is no Connection Preferences > WiFi Only that I could find on this screen or anywhere in options.
0
 
Raymond PengSystems EngineerCommented:
What version OS are you using? any IT policies set on the device?  Are you able to set it to factory default?  If the phone was on a BES in the past, there are probably policies in place.  I recommend setting the device to factory state.

options menu - security options - general settings - bb menu - wipe handheld - enter password

Reload OS

http://crackberry.com/blackberry-101-lecture-12-how-reload-operating-system-nuked-blackberry
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
HomerTNachoCheeseAuthor Commented:
I was hoping to avoid nuking the device, but it looks like the best method at this point.  We had it connected to BES, but I don't ever remember setting any restrictions on BES that would affect this.

The OS is v5.0.0.1015 (Bundle 1656, Platform 4.2.0.442).

I will nuke it after lunch and see where that takes this issue.
0
 
Raymond PengSystems EngineerCommented:
Thanks, do you also have a SIM handy assuming you u have ATT / Tmo in case we need to insert it for the device to pick up another 'possible' mobile connection
0
 
HomerTNachoCheeseAuthor Commented:
It was from Verizon.  There is a card in the SIM slot.
0
 
HomerTNachoCheeseAuthor Commented:
Nuking worked.  During the initial setup process, I just told it to not use the SIM card to automatically select mobile networks (it said something to that effect).  Afterwords, the only option I had for browsing was hotspot.
0
 
HomerTNachoCheeseAuthor Commented:
Wiping was necessary.  BES policies made no difference, as they were still present even after wiping.  The SIM card seems to have been a big part of the problem.  Maybe even removing it could have helped, but simply not using it (or enabling) after the wipe was key.

I did notice that before wiping that if I tried using Bing it would immediately fail, and under Bing's options, it wanted to use Internet Explorer as its browser, and selecting HotSpot would not hold.  Probably there was some setting or bug that would not allow keeping things set as hotspot, but as hotspot became the ONLY option after a wipe, that is all that could be used and everything worked properly.

Thanks for the help.
0
 
Raymond PengSystems EngineerCommented:
thanks for the update, glad it's all working out.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now