Permissions problem - Applicaiton Data

I am running Windows 7 home.  

I have a directory that I am not being allowed to see that I think I should be allowed to see.  It is in a directory called Users\Woody\Application Data.  (Woody is my user name).

When I click on it I get an error message of Access Denied.  I thought it might just be a problem of not having permissions set.  In the security tab I set permissions for everyone to full but I am still not able to access the folder.

It may be of importance to note that the icon associated with folder does not look normal. I has a little arrow on it curved and pointing to 2:00 oclock.

One of my programs is telling me to look in this folder for a certain file, but at present I am unable to do so.  Anyone know why?
WoodrowAAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CSI-Windows_comCommented:
That particular folder is actually a symbolic link for compatibility.

It actually points to Users\Woody\AppData\Roaming.

You have probably told Windows to display all system folders (Under Folder Options in control panel) and that is why you are seeing the folder.

Symbolic links look like real folders to your backup programs - so Microsoft denies permissions to "list" the items in the folder or else backups would take two copies (actually many more copies of some folders).

You can verify what I am telling you by opening a command prompt and change to your profile folder (should default there).

Then type "Dir /AL" and press enter.  The "L" stands for "links".  Even though the links are hidden they will show when using the "/AL"

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pjmabinCommented:
Try setting the permissions of all the group or users names to full on the Users folder, and make sure you put a check in the “Include inheritable permissions from this object's parent” box. You may need to do this to your User folder also.
CSI-Windows_comCommented:
I guess I should have been clear about the permissions in my response.

You don't actually need permissions to that folder and should not change the permissions.

Although you can't list the contents on Application Data directly, you can view subfolders (and so can your programs that might have this folder location hard coded into them).

Try this:

*) Open c:\users\woody\appdata\roaming.
*) Take note of a subfolder - for instance "C:\users\woody\appdata\roaming\Microsoft"
*) Now type sub-folder into windows explorer (don't click the tree to navigate there) as such "C:\users\woody\application data\microsoft" and you will see that you can get to and list sub folders.

This is how Microsoft has made sure any software that is hard coded to the Application Data folder will still work.
WoodrowAAuthor Commented:
Excelent - Thank you very much
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.