Solved

Exchange 2003 > 2010 Migration - Relay needed?

Posted on 2012-03-29
11
420 Views
Last Modified: 2012-04-03
Hi,

I am on the verge of completing my first Exchange 2003 > 2010 upgrade and I'm 99% there...

All that's left now is final testing of ActiveSync from various mobile devices and the actual mailbox moves/old server decommissioning.

I had a bit of a headache with SSL certificates and an Outlook 2007 popup, but that is now resolved.

The only outstanding issue I have is this.................we have a 3rd party CRM/database system which we use for sending mail to clients & other contacts.

At the moment, it is set up using the following config:

sender e-mail address: user@domain.com
reply e-mail address: user@domain.com

Server: 192.168.1.XXX
Port: 25
Username: domain\username
Password: *password*
Authentication Method: AUTO
SSL? (Tick box): NO

I'm trying to get this application to send via Exchange 2010 but haven't had any joy. I've changed the IP address accordingly and swapped the username/password for a user that has a live 'Exchange 2010' mailbox'.

I have tried all different combinations of SSL on/off and authentication methods but I don't seem to be getting anyway.

Please could someone look into this as soon as possible, I want to carry out the migration this weekend but need to ensure that this e-mail sending method is working fine.

Thanks in advance!!

PS. Error log is attached
0
Comment
Question by:robsamuel2k8
11 Comments
 

Author Comment

by:robsamuel2k8
ID: 37782709
Sorry, here's the attachment
Error-Log.txt
0
 
LVL 41

Assisted Solution

by:Amit
Amit earned 125 total points
ID: 37782720
0
 
LVL 4

Expert Comment

by:VictorTarasov
ID: 37782721
SSL must be trusted. Including the organization that issued the certificate.
0
 
LVL 4

Accepted Solution

by:
Red_Tech earned 125 total points
ID: 37782742
0
 
LVL 2

Expert Comment

by:FostWare
ID: 37782767
I've had issues getting authenticated SMTP to happen from CLI, so I think I ended up creating an anonymous relay (as per http://technet.microsoft.com/en-us/library/bb232021.aspx) but the source IP was limited and I think I skipped the Add-ADPermission step, since Anonymous connections weren't allowed.

You could also try just running the Add-ADPermission step for that user on a new anonymous relay connector.
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 41

Expert Comment

by:Amit
ID: 37782771
Logs says you are unable to relay, configure the relay connector first.
0
 
LVL 38

Expert Comment

by:Adam Brown
ID: 37782890
You need to configure your Receive Connector to allow anonymous connections from that IP address. Create a new Receive connector in Exchange 2010 (from Server Configuration\Hub Transport), enter the IP address for the remote mail sending server into the IP addresses tab, and select only Anonymous and Exchange Users on the Permission groups tab and TLS,Basic, and Exchange authentication on the Authentication tab.
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 125 total points
ID: 37783011
You need to configure a new Receive Connector and also allow it to Relay.  The MS Guide will show you the exact steps to do both and set this up successfully:

http://technet.microsoft.com/en-us/library/bb232021.aspx
0
 
LVL 23

Assisted Solution

by:Malli Boppe
Malli Boppe earned 125 total points
ID: 37785342
0
 

Author Comment

by:robsamuel2k8
ID: 37794890
Hi, I moved all of the mailboxes on Saturday and it all went smoothly. I've re-configured our users' mobiles and I'm working on the CRM e-mail access this morning.

I'll give the links above a try now and let you know how I get on.

Thanks for the advice so far, I will provide feedback as I go through the potential solutions.
0
 

Author Comment

by:robsamuel2k8
ID: 37800470
Hi, I've set up a 3rd receive connector and it seems to be working, albeit with a 5-20 second delay between clicking send and getting the 'message sent' popup.

I'm also having trouble with POP3. I've configured it right and tested it internally using PowerShell but one application we use that needs POP3 is not connecting.

Thanks for your comments, I'll do some research on here to figure out the other issues.

Many thanks!
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now