Solved

Exchange OAB expected response

Posted on 2012-03-29
4
683 Views
Last Modified: 2012-04-04
I have a client that is running SBS 2008, they weren't using Exchange but the services were running and it seemed like some configuration had been done on it.   I setup the exchange server and got everything working except outlook would hang and eventually time out saying "the operation failed: an object could not be found"  I looked up the error code and it suggested they were having problems downloading OAB.  After much troubleshooting and trying various things, i have done the following setup:

rebuilt the OAB
changed url so it resolves to server correctly
set permissions to allow authenticated users on oab.xml
there was a web.config file created, changed permissions for read access to authenticated users

now, on the server,if i go to https://localhost/oab/<oabcode>/oab.xml  it loads the xml file fine

but if I browse to https://domainnamegoeshere.net/oab/<oabcode>/oab.xml  I am prompted with an authentication window, which does not accept my credentials, or any domain users, and after three tries returns a "401.1 - unauthorized" error

is this the expected response? os is my permissions for this web directory messed up?

thanks,

- Kalen
0
Comment
Question by:gtmc
  • 3
4 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 37782945
The OAB is located using Autodiscover.  Is ther a 3rd party SSL certificate installed (SAN / UCC - multi name) with the following names included:

remote.externaldomainname.com (or whatever you chose to use)
autodiscover.externaldomainname.com
servername.internaldomainname.local
servername
sites

Is there also an Autodiscover A record created externally in DNS that resolves to the IP address of your SBS server (public IP address not internal IP address)?
0
 

Author Comment

by:gtmc
ID: 37783030
Thanks for the response

I would like to know what the expected response for browsing to that URL is?? and if it is to prompt for credentials, should a mailbox users credentials work????
















My SAN cert contains:
mail.externaldomainname.com
autodiscover.externaldomainname.com
sites

I have created all A records and added DNS entries on the server, to use external names, on internal network. i.e. browsing to autodiscover.externaldomainname.com internally resolves the exchange server correctly.

I used https://www.testexchangeconnectivity.com to verify and all tests pass.

this problem is only on the internal network
0
 

Accepted Solution

by:
gtmc earned 0 total points
ID: 37787711
for anyone needing to know the expected response is to be prompted for credentials.  

In my case i could not get any credentials to work when browsing on the server.  But once i was at a workstation, browsing to the oab url prompted for credentials, autofilled the username, and i used the password for that user and it loaded the oab.xml.
0
 

Author Closing Comment

by:gtmc
ID: 37805142
My question was not answered.  Once i configured the settings correctly I was able to verify what the answer to my question.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Are you unable to connect or configure Hotmail email account in Microsoft Outlook 2010, 2007? Or Outlook.com emails are not downloading to Outlook? Lets’ see the problem and resolve Outlook Connector error syncing folder hierarchy (0x8004102A).
This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question