Is Exchange set up correctly if my internal domain shows up in the message headers

I am using a SBS 2011 Standard Server with Microsoft Exchange 2010. I noticed that the message headers contain my server's local address based on the internal domain.  Is this a problem? If so, how do I fix it?


Some important details
Exchange/SBS Server name = ALOHA
Internal domain = contoso.local
External domain = office.contoso.com
PTR record for external domain= yes
Active certificate installed for external domain = yes


Here's what the message headers look like from a message sent to a GMail account:
Delivered-To: [outside email address]
Received: by 10.229.13.16 with SMTP id z16csp215614qcz;
        Thu, 29 Mar 2012 09:29:02 -0700 (PDT)
Received: by 10.224.59.204 with SMTP id m12mr1076284qah.37.1333038541705;
        Thu, 29 Mar 2012 09:29:01 -0700 (PDT)
Return-Path: <john@contoso.com>
Received: from office.contoso.com (office.contoso.com. [24.106.182.42])
        by mx.google.com with ESMTPS id a5si7331219qaf.3.2012.03.29.09.29.00
        (version=TLSv1/SSLv3 cipher=OTHER);
        Thu, 29 Mar 2012 09:29:01 -0700 (PDT)
Received-SPF: pass (google.com: domain of john@contoso.com designates 24.106.182.42 as permitted sender) client-ip=24.106.182.42;
Authentication-Results: mx.google.com; spf=pass (google.com: domain of john@contoso.com designates 24.106.182.42 as permitted sender) smtp.mail=john@contoso.com
Received: from ALOHA.contoso.local ([fe80::406:e642:3e72:ba5c]) by
 ALOHA.contoso.local ([fe80::406:e642:3e72:ba5c%11]) with mapi id
 14.01.0355.002; Thu, 29 Mar 2012 12:29:00 -0400
From: John Doe <john@contoso.com>
To: "[outside email address]" <[outside email address]>
Subject: does this come from contoso.com?
Thread-Topic: does this come from contoso.com?
Thread-Index: Ac0NyQgEnNZRF357SiGPmzApJUGs6g==
Date: Thu, 29 Mar 2012 16:28:59 +0000
Message-ID: <E69C56AA5B277546B477C3E95B58C9280277621B@ALOHA.contoso.local>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-originating-ip: [192.168.1.33]
Content-Type: multipart/alternative;
	boundary="_000_E69C56AA5B277546B477C3E95B58C9280277621BALOHAcontosolo_"
MIME-Version: 1.0

Open in new window


Thanks!
eglescoutAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam BrownSr Solutions ArchitectCommented:
You'll want to look at the settings for your send and receive connectors. On the first tab of the properties for each there is an FQDN for the connectors to use. If that is set as your local domain, you should probably change that to your external domain :D

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eglescoutAuthor Commented:
Thanks.  The send connector is set to office.contoso.com.

I have  three receive connectors:
Default ALOHA
Windows SBS Fax Sharepoint Receive ALOHA
Windows SBS Internet Receive ALOHA

The internet one is set to office.contoso.com.

Is there anything else I need to check?
eglescoutAuthor Commented:
I was waiting for a confirmation that I had set up everything or anything else needed to be checked.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.