Solved

VMtool services not running

Posted on 2012-03-29
10
494 Views
Last Modified: 2012-03-30
For one of my server, VMtool icon in tray is "RED" colored and i cant see teh vmtool services on the server. Please let me know how to enable back the VMtool without down time
0
Comment
Question by:kbjijo
  • 5
  • 4
10 Comments
 
LVL 119
ID: 37783999
You need to re-install VMware Tools.

This requires a restart, so you cannot avoid any downtime.
0
 
LVL 30

Expert Comment

by:IanTh
ID: 37784001
go to the vm do a right click and there is a link to reinstall vm tools its probably an older version it can happen
0
 

Author Comment

by:kbjijo
ID: 37784103
Thanks for the update, means no luck without down time

The vmtool issue occured while taking the clone
"Cannot clone USBMAIPD01v: Cannot create a quiesced snapshot because the (user-supplied) custom prefreeze script in the virtual machine exited with a nonzero return code.error "

If i changed the vmtool box Script ( Uncheck script option), will it work and can avoid Down time
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 119

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 500 total points
ID: 37784122
you need to unininstall, restart, reinstall, restart.

Im afraid you will not be able to install, reinstall fix tools with downtime.
0
 

Author Comment

by:kbjijo
ID: 37784199
Oh.. !

If i can able to take the clone by shutting down the VM ( Script error during online clone)
0
 
LVL 119
ID: 37784209
VMware Tools Service is required to Quiece the VM, for hot clone, when VM is on.
0
 

Author Comment

by:kbjijo
ID: 37784224
Means i can do the clone on Offline without issue, am i right
0
 
LVL 119
ID: 37784231
correct.
0
 

Author Comment

by:kbjijo
ID: 37784234
OK, thanks a lot, let me get the down time
0
 

Author Closing Comment

by:kbjijo
ID: 37789642
I have reinstalled the VM and now its fine for cloning
Thanks for the help
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If we need to check who deleted a Virtual Machine from our vCenter. Looking this task in logs can be painful and spend lot of time, so the best way to check this is in the vCenter DB. Just connect to vCenter DB(default DB should be VCDB and using…
This article runs through the process of deploying a single EXE application selectively to a group of user.
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:
This video shows you how to use a vSphere client to connect to your ESX host as the root user. Demonstrates the basic connection of bypassing certification set up. Demonstrates how to access the traditional view to begin managing your virtual mac…

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question