Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server The attempt to ping the endpoint failed.

Hi Experts,
Im trying to move my on-premises exchange 2003 on windows server 2003 SP3 to the cloud with Exchange Online on Office 365, and Im trying to Test my connection RPC over HTTP and I get this error.

Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server mail.mydomain.com.
       The attempt to ping the endpoint failed.
        
      Additional Details
       The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process.

I double check the registry entries, also I check with netstat that my server is listening on port 6001 but I still got the issue.
I've been looking for an answer on this for a couple of days without luck
My environment is, Exchange server 2003 running mirrored with Neverfail, I have an ISA Server 2006

I will appreciate your help
miguelitxAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

StuWhitbyCommented:
Firstly, check

  rpcinfo -p mail.mydomain.com

to ensure that the rpc services are running correctly and listing the endpoints you want to reach.  The default portmapper entry is port 111 - may show up as sunrpc.  This will need to be available through the firewall etc, though I'd expect it's generally passed through okay.  

If that gives you nothing, get hold of wireshark from www.wireshark.org, install it on your client, and set up a capture filter of "host=mail.mydomain.com", then try your ping again, stop the capture, and look at the output.  This should show you fairly quickly where the problem is.  If you can't interpret the output, save it as a .pcap file, post it here and I'll take a quick look.
0
footechCommented:
I'm assuming you're using www.testexchangeconnectivity.com.  Did you choose to manually specify the server settings, and enter the internal FQDN of your mailbox server (the backend server if you're using a FE/BE configuration) for the "Exchange server" field?
0
miguelitxAuthor Commented:
Yes, im using www.testexchangeconnectivity.com 
And no, im using external domain name
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

footechCommented:
Use the external name for the RPC proxy field, but use the internal name for the Exchange server field.
2

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
footechCommented:
I don't know what further information I could give you that would merit a better grade.  It's as simple as following the instructions at their site.
0
llovingCommented:
I followed this thread and must agree with footech. Exact answer to my situation which I believe is the same as the original post.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.