Solved

DNS does not resolve correctly via VPN

Posted on 2012-03-29
11
538 Views
Last Modified: 2012-03-30
Our customers use VPN to RDP into their respective workstations on occasion to work. We recently discovered that we can't ping or RDP to computer names; however the FQDN for workstations does work.
0
Comment
Question by:MIT-Techs
  • 6
  • 4
11 Comments
 
LVL 22

Expert Comment

by:chakko
ID: 37784512
2 options I think will solve this.

Setup WINs
Or make sure that there is a DNS suffix configured in the TCP/IP v4 settings on the users computer.  This will be on the Advanced area at the DNS tab.

Add your domain suffix.  Then when they need to access by name it will use the suffix to form a FQDN for dns resolution.
0
 

Author Comment

by:MIT-Techs
ID: 37784533
WINS is configured on the server, but still unable to ping or connect to anything by name.
0
 
LVL 22

Expert Comment

by:chakko
ID: 37784541
what type of VPN are you using.  the VPN client may not be using WINs or may not be able to use the WINs through the tunnel.  

The DNS suffix should make it work if that is possible to configure.
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 
LVL 22

Accepted Solution

by:
chakko earned 500 total points
ID: 37784545
in the WINs manager can you see the entries for the workstations in there.  Are they registering automatically with WINs?
0
 

Author Comment

by:MIT-Techs
ID: 37784553
Windows PPTP VPN.

It worked for almost a year. We recently decommissioned a domain controller that was the DHCP/DNS server. The new DHCP/DNS server is Server 2008 and everything seems to be configured correct.

DNS is AD integrated BTW and the DHCP is authorized in AD as well.
0
 

Author Comment

by:MIT-Techs
ID: 37784585
How do I get to the WINS manager in server 2008 r2?
0
 
LVL 22

Expert Comment

by:chakko
ID: 37784917
It should be located in the Administrative Tools area

You should also be able to load the mmc console and then add the snapin for it.
0
 
LVL 22

Expert Comment

by:chakko
ID: 37784930
in the DHCP service you may need to specify the WINS server as a scope option
0
 
LVL 22

Expert Comment

by:chakko
ID: 37784975
Also, check in your Routing and Remote Access, Server Properties on the IP tab

look for a checkbox for Broadcast Name resolution and verify it is enabled.
0
 
LVL 77

Expert Comment

by:arnold
ID: 37786637
As part of the pptp configuration on the client, make sure that the LAN dns servers are listed as well as add as other experts pointed out the LAN ad domain into the list.
0
 

Author Closing Comment

by:MIT-Techs
ID: 37787641
I checked the WINS manager and found the service was not working. I removed and re-added the service. All seems to be working now. Thank you for your help!
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Occasionally you run into the website or two that will not resolve properly using your own DNS servers.  Some people simply set up global forwarders for their DNS server.  I don’t recommend doing this because it can cause problems resolving addresse…
I've written instructions for one router type, but this principle may be useful for others of the same brand and even other brands of router. Problem: I had an issue especially with mobile devices that refused to use DNS information supplied via…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question