Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Exchange email - external adress shown

Posted on 2012-03-29
5
Medium Priority
?
1,132 Views
Last Modified: 2012-03-29
Hello! I really need some assistance here!
I have set up this new exchange 2010 server and some of our emails are bouncing cause it looks like they are send from our local domain adress (we dont have certificate on this one). I want my adress to be like on our 2003 sever!

What is wrong in the Exchange 2010 one? (its mail1)
Did this test on http://www.mtgsy.net/dns/utilities.php

Testing mail1.domain.com, preference = 20
Checking to see if mail1.domain.com is in any of the popular RBL's - PASSED - Not found in any RBL's
Trying to connect to mail1.domain.com
SUCCESS
220 mail.DOMAIN.LOCAL Microsoft ESMTP MAIL Service ready at Thu, 29 Mar 2012 23:30:43 +0200
EHLO MTGSY.NET
250-mail.DOMAIN.LOCAL Hello [109.73.72.163]
250-SIZE
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-X-ANONYMOUSTLS
250-AUTH NTLM
250-X-EXPS GSSAPI NTLM
250-8BITMIME
250-BINARYMIME
250-CHUNKING
250-XEXCH50
250-XRDST
250 XSHADOW
MAIL FROM:<postmaster@mtgsy.net>
250 2.1.0 Sender OK
RCPT TO:<derp@mail.com>
250 2.1.5 Recipient OK
QUIT
221 2.0.0 Service closing transmission channel


Testing mail2.domain.com, preference = 10
Checking to see if mail2.domain.com is in any of the popular RBL's - PASSED - Not found in any RBL's
Trying to connect to mail2.domain.com
SUCCESS
220 mail2.domain.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.4675 ready at Thu, 29 Mar 2012 23:30:52 +0200 
EHLO MTGSY.NET
250-mail2.domain.com Hello [109.73.72.163]
250-TURN
250-SIZE
250-ETRN
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-8bitmime
250-BINARYMIME
250-CHUNKING
250-VRFY
250-X-EXPS GSSAPI NTLM LOGIN
250-X-EXPS=LOGIN
250-AUTH GSSAPI NTLM LOGIN
250-AUTH=LOGIN
250-X-LINK2STATE
250-XEXCH50
250 OK
MAIL FROM:<postmaster@mtgsy.net>
250 2.1.0 postmaster@mtgsy.net....Sender OK
RCPT TO:<derp@mail.com>
250 2.1.5 derp@mail.com 
QUIT
221 2.0.0 mail2.domain.com Service closing transmission channel

Open in new window

0
Comment
Question by:tigerffs
  • 2
  • 2
5 Comments
 
LVL 44

Expert Comment

by:Adam Brown
ID: 37785017
There's a setting on your send and receive connectors in Exchange that determines what is shown as the Server's name when another server or client connects to it. You can change this to match your External domain name fairly easily. If you open your send connector's properties screen (Organization Configuration\Hub Transport\Send Connectors in the EMC) the tab that opens up will have an option that says "Specify the FQDN this connector will provide..."
Enter the external name for your mail server in the text box below that. Do the same for your receive connector (Server Configuration\Hub Transport\Send connectors)
0
 
LVL 22

Expert Comment

by:chakko
ID: 37785027
do you mean you want to change it from mail.domain.com to mail1.domain.com

in the Server area EMC go to the Hub Transport.  In the Receive connector change the name to be mail1.domain.com

Also, in the Organization level check your Send connector and you may also need to change it to mail1.domain.com also

Lastly, make sure your reverse DNS is setup properly.  You will normally need to request your ISP to create the reverse DNS records for you.
0
 
LVL 3

Author Comment

by:tigerffs
ID: 37785048
Thank you very much. I got a error when trying to set the FQDN on one of the recive-connectors though - Default EMAIL. (I have 2, one is called Client EMAIL and och Default EMAIL.)

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
The following error(s) occurred while saving changes:

Set-ReceiveConnector
Failed
Error:
If the AuthMechanism attribute on a Receive connector contains the value ExchangeServer, you must set the FQDN parameter on the Receive connector to one of the following values: the FQDN of the transport server "EMAIL.domain.local", the NetBIOS name of the transport server "EMAIL", or $null.




--------------------------------------------------------
OK
--------------------------------------------------------

Open in new window

0
 
LVL 44

Accepted Solution

by:
Adam Brown earned 2000 total points
ID: 37785058
Go to the Authentication tab on the properties of that connector and remove the checkbox next to Exchange Server Authentication. Realistically, only Transport Layer Security (TLS) needs to be checked there.
0
 
LVL 3

Author Closing Comment

by:tigerffs
ID: 37785125
I wanna hire you! :D
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Eseutil Hard Recovery is part of exchange tool and ensures Exchange mailbox data recovery when mailbox gets corrupt due to some problem on Exchange server.
Mailbox Corruption is a nightmare every Exchange DBA wishes he never has. Recovering from it can be super-hectic if not entirely futile. And though techniques like the New-MailboxRepairRequest cmdlet have been designed to help with fixing minor corr…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Suggested Courses

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question