Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

WSUS 3.0 - Computers not in WSUS console

Posted on 2012-03-29
12
Medium Priority
?
546 Views
Last Modified: 2012-03-29
Hi Guys,

     I am having trouble adding computers to the WSUS console.  They are currently connected to the domain but do not populate the list.  We are currently using the Updates console to manage unassigned computers, however, there are some servers in our environment that are not in the console.  How do we get them in there?

Your help is appreciated

Regards,
0
Comment
Question by:BCSITS
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
12 Comments
 
LVL 21

Expert Comment

by:motnahp00
ID: 37785252
Do you already have a GPO or LGPO configured to point your clients to the WSUS?
0
 

Author Comment

by:BCSITS
ID: 37785266
Yes, we are currently using a GPO for Windows updates only, however, not all servers in the OU's that it applies to are in the list and this is what i am trying to achieve.

I have also synchronized the WSUS console but the servers did not populate.
0
 
LVL 21

Expert Comment

by:motnahp00
ID: 37785271
Out of curiosity, did you clone any of your servers?
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 

Author Comment

by:BCSITS
ID: 37785282
No cloning done.  They are VM's though.  Other VM's are not having this issue.  I ran RSOP for Computer settings only and i am having trouble reading th results.  I am having trouble checking the Administrative Settings though.  When i click on that Tab, the MMC freezes and i have to force shutdown and start the MMC again.  I suspect that this may be the issue but not sure why.

Any ideas?
0
 
LVL 21

Accepted Solution

by:
motnahp00 earned 2000 total points
ID: 37785285
Not sure about the MMC issue but try this on a non-reporting VM:

net stop wuauserv

REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v AccountDomainSid /f

REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v PingID /f

REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v SusClientId /f

net start wuauserv wuauclt /resetauthorization /detectnow

Pause
0
 

Author Comment

by:BCSITS
ID: 37785326
I tried to run the first  two registry commands but got an error "the system was unable to find the specified registry key"

The last command completed successfully.  restarted the services and reran the RSOP.  still got the following error messages "RSOP.MSC Error: Error 64 help string specified. The file can not be loaded"

thanks
0
 
LVL 21

Expert Comment

by:motnahp00
ID: 37785331
When you click Windows Update, you are seeing "Managed by your system administrator" right?
0
 

Author Comment

by:BCSITS
ID: 37785340
If you mean the the Automatic updates window is greyed out then yes.  I managed to fix the RSOP issue and found that the correct policies are applying.  It has three settings applied.

What do do with the downloads, specify location of WSUS server and whether or not to restart after updates or not.

this is installed on a Windows 2003 server btw.
0
 

Author Comment

by:BCSITS
ID: 37785348
ok the servers have populated the list now.  i guess that it took a bit of time for them to get in the list.  i believe that resetting the susclientid value was the key here.

thanks for all your help.  you were spot on.
0
 

Author Closing Comment

by:BCSITS
ID: 37785352
great answers and speedy responses.
0
 
LVL 21

Expert Comment

by:motnahp00
ID: 37785353
You have "Specify intranet Microsoft updates service location" in this format http://X.X.X.X (both settings) in this format, right?
0
 
LVL 21

Expert Comment

by:motnahp00
ID: 37785357
No problem. I had a similar issue with VMs not reporting because I cloned them. The registry key recreation resolved my problem. I'm glad everything works!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you ever had a hard drive that you can't boot into, but need to change the registry? Here is the solution! This article guides you through accessing and editing a registry of a non-primary drive. To read registry information on a non-prim…
I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question