Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Import button in phpmyadmin doesn't work

Posted on 2012-03-30
7
Medium Priority
?
955 Views
Last Modified: 2012-04-08
Hi,
I have Linux Debian Squeez, mysql 5.1.61 and phpmyadmin 3.3.7deb7.
When I go to import tab and browse file.sql and press go i does nothing.
It doesn't return no error.

If I copy content of that file file.sql and paste it in to SQL query in same phpmyadmin it will import that table/database.
If I copy that file directly on server and import from command line it also works.

I tried to reinstall phpmyadmin but the problem stays the same.

I have 3 more servers with same configuration and the import button works. (same debian, same versions of mysql, phpmyadmin).
0
Comment
Question by:eihp
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 11

Expert Comment

by:legolasthehansy
ID: 37787657
Do you see any errors under /var/log/httpd/error_logs (or similar path)
0
 
LVL 7

Expert Comment

by:Jayachandran Palanisamy
ID: 37792296
Hi,
Please try the followings.

1.download the latest version of PMA(3.4.10.2) and have a try with import option
http://downloads.sourceforge.net/project/phpmyadmin/phpMyAdmin/3.4.10.2/phpMyAdmin-3.4.10.2-english.tar.gz?r=http%3A%2F%2Fwww.phpmyadmin.net%2Fhome_page%2Fdownloads.php&ts=1333250325&use_mirror=cdnetworks-kr-1

2.Find the default php.ini path on your server and compare the same with another working servers.
To find php.ini conf file.
php -i |grep php.ini

Open in new window


Check the following values.
file_uploads 
post_max_size
upload_max_filesize

Open in new window


If you found something different then change the values and restart the apache.
/etc/init.d/apache2 restart

Open in new window


Good luck :)

Jay
0
 

Author Comment

by:eihp
ID: 37796189
I have this error when I press upload button:
Mon Apr 02 15:52:20 2012] [client xxx.xxx.xxx.xxx] Symbolic link not allowed or link target not accessible: /home/httpd/htdocs/mybaza/js/mootools.js, referer: http://www.xxxx.hr/mybaza/main.php?token=d921ed84e1e31d63d2d545d9141c4a55
0
Docker-Compose to Simplify Multi-Container Builds

Our veteran DevOps Author takes you through how to build a multi-container environment, managed with a single utility in order to simplify your deployments.

 
LVL 11

Expert Comment

by:legolasthehansy
ID: 37796652
Check if Options FollowSymLinks is defined for
/home/httpd/htdocs

should be something like this in /etc/apache2/conf/apache2.conf (or your apache config file)

<Directory /home/httpd/htdocs>
Options FollowSymLinks
</Directory>

Also make sure Options None doesn't follow after this statement.
0
 

Author Comment

by:eihp
ID: 37799881
In my /etc/php5/apache2/php.ini I have
file_uploads = On
post_max_size = 64M
upload_max_filesize = 256M

File I was try to upload is 35KB

I tried to put in /etc/apache2/sites-available/xxx
<Directory /home/httpd/htdocs/mybaza>
Options FollowSymLinks
Order deny,allow
Deny from all
Allow from xxx.xxx.x.0/24
</Directory>

And after /etc/init.d/apache2 restart, but it didn't help.
Still the same error
0
 

Accepted Solution

by:
eihp earned 0 total points
ID: 37800443
I find the solution for me.
The problem was that I copied the phpmyadmin from /usr/share/phpmyadmin to a new locaton. From that new locaton import button didn't work.
When I put it back to /usr/share/phpmyadmin it works. Still don't know why but it is working now so I won't bother any more.
0
 

Author Closing Comment

by:eihp
ID: 37820807
no reson
0

Featured Post

Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question