Gmail delivery issue

Ok this is really weird.  We have an Exchange 2003 Enterprise server with Postini filtering incoming and outgoing messages.  It looked as though we might be having mail flow issues this morning.  So I jumped on mxtoolbox and did an mx lookup...everything was fine.  Checked the event logs on the Exchange server...everything fine.  Checked the queue on the Exchange server...clean.  Tested sending mail from external accounts on hotmail, yahoo, gmail.  All are coming in fine and quick from hotmail and yahoo but my personal gmail never shows up. So I remote into my home machine and sent a test message from my gmail account to my account on the Exchange server thinking it could be an ISP issue...never shows up.  I have my wife send me a test message from her gmail...pops in right away.  A guy who sits right next to me sends me a test message from his gmail account...pops in right away.  I checked the logs on Postini and it doesn't show any mail coming to my account from my gmail.  But I can send email from my gmail account to other addresses within our domain just not mine.  And there is nothing in Outlook junk mail folder.

Question is...what else can I check here and who can I even contact about this issue?
FvengAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

n2fcCommented:
Did you link the exchange email account to the gmail account via the gmail account settings?

If so then gmail may be bypassing the actual send to the exchange server as redundant since it knows it came from you.
0
FvengAuthor Commented:
Nope.  Just a standard personal gmail account.  The test messages that I sent a while ago are just starting to arrive.  1.5 hrs after sent.  Not sure what is going one but all of my outgoing emails from my gmail account are taking over an hour to arrive.  I sent some test emails to other domains and I'm just getting replies back from them too.  Very weird.  Guessing the mail server that my gmail account resides is having issues.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.