Solved

Iscsi Storage in VMware

Posted on 2012-03-30
38
947 Views
Last Modified: 2012-05-25
Good Morning,

I recently added some Iscsi storage to an esxi host a nd did all the bindings for it to come. When I check the storage adapters its is showing the paths to the storage . However, I dont see it added as a datastore.
0
Comment
Question by:alli87
  • 20
  • 18
38 Comments
 
LVL 117

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE) earned 500 total points
Comment Utility
0
 

Author Comment

by:alli87
Comment Utility
I have done all of the bindings and the paths come up . However, when i go to add the datastore the window is empty (see attached files).
Iscsi-Paths.PNG
Iscsi-Paths-2.PNG
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
I can see there is LUN0 presented.

How large have you made this LUN?

is this a new LUN or re-used LUN?
0
 

Author Comment

by:alli87
Comment Utility
The size of the Lun is 3.41 TB . I have migrated two virtual machines to this Lun from another Host . However I want to get this host to see the same Lun now.
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
What version of ESX? 4.x?

Max size of LUN is 2TB-512bytes
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
Configuration Maximums for VMware vSphere 4.1

http://www.vmware.com/pdf/vsphere4/r41/vsp_41_config_max.pdf
0
 

Author Comment

by:alli87
Comment Utility
My Apologies , The size of the volume is 1.3 TB. See the attached file showing the volume on the host .
Volume-Size.PNG
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
this lun is used on another hosts?
0
 

Author Comment

by:alli87
Comment Utility
Yes it is
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
it's not VMFS 5?
0
 

Author Comment

by:alli87
Comment Utility
No its a VMFS 4 volume
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
so this single 1.3TB LUN VMFS3 is presented two other hosts and is working?
0
 

Author Comment

by:alli87
Comment Utility
It is Presented to one other host and is working
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
try the following esxcfg-volume -l

example output


~ # esxcfg-volume -l
VMFS3 UUID/label: 4cc89503-f054d0d4-2865-00221958e471/nas3-vmfs
Can mount: Yes
Can resignature: No (the volume is being actively used)
Extent name: naa.600140588e9bab7d2b7ed4b53dadc1de:1     range: 0 - 1048319 (MB)

and then

esxcfg-volume -m 4cc89503-f054d0d4-2865-00221958e471 (UUID from above)

or

esxcfg-volume -m nas3-vmfs (or friendly datastore name)
0
 

Author Comment

by:alli87
Comment Utility
When I run this command (esxcfg-volume -l) it goes back to the root prompt with no error. I am not sure if this means it is successful but I do not get the output you get above .
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
if means it cannot find any volumes.
0
 

Author Comment

by:alli87
Comment Utility
Ok , I also just restarted the hosts and still no luck.
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
Create a new lun and present to this host as a test
0
 

Author Comment

by:alli87
Comment Utility
I created a new lun and presented it to the second host and the same thing happens , it comes up under storage adapters but not under datastore.
Lun-test.PNG
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
did you try presenting to the first host?
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
or is the second host, the host you are having issue with?

when you click add storage the LUN does not appear?
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
there must be something wrong on this host, or configured differently to the other.
0
 

Author Comment

by:alli87
Comment Utility
The new Lun has now come up for all hosts
0
 

Author Comment

by:alli87
Comment Utility
Correction it appears for all the hosts in the add storage section . However when I try to add it to hosts two and three I get an error . When i try to add it to the first host i get through . I know there is a problem with Hosts two and three but do you have  any idea what it could be ?
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
error message is?
0
 

Author Comment

by:alli87
Comment Utility
Call "HostDatastoreSystem.CreateVmfsDatastore" for object "datastoreSystem-224" on vCenter Server "friedrice.MEDIANET.local" failed.
Operation failed, diagnostics report: Unable to create Filesystem, please see VMkernel log for more details.
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
okay, is this a new LUN, or a reused LUN, often errors occur like this is because the lun, is reused and may have existing partitions or data that cannot be deleted or erased.

check the vmkernel.log for further details, from the console
0
 

Author Comment

by:alli87
Comment Utility
Is there anything specific to look for in them ? I have been looking at them for the past half hour and I'm not seeing anything popping out at me.
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
is this a newly created lun or old lun?
0
 

Author Comment

by:alli87
Comment Utility
Its a new one i created after having the problem with the initial 1.3 Tb LUN
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
whats the size?
0
 

Author Comment

by:alli87
Comment Utility
5 GB
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
5 GB? that' small?
0
 

Author Comment

by:alli87
Comment Utility
Yeh I just created one just big enough to come up under vmware . Do you think the size is an issue ?
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
try a larger LUN 20GB
0
 

Author Comment

by:alli87
Comment Utility
I just tried with a 600 GB LUN while giving access to only one host and still got the same error
0
 

Author Comment

by:alli87
Comment Utility
I Have tried another combination buy configuring a new server with ESXi and adding the same 1.3TB LUN through Iscsi and it comes up with no problems . This means the issue is with the Dell R610. I tried reinstalling ESXi on the R610 and redoing the entire configuration and still it does not come up , however when I connect to it I do not get the error anymore . I have also checked the BIOS and all virtualization features are enabled there . Any ideas what could be the difference with the R610 ?
0
 
LVL 117

Expert Comment

by:Andrew Hancock (VMware vExpert / EE MVE)
Comment Utility
it would be time to check the logs on the ESXi server

see here

http://xtravirt.com/vmware-esxi-4-log-files
0

Featured Post

Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

Join & Write a Comment

Suggested Solutions

This is an issue that we can get adding / removing permissions in the vCSA 6.0. We can also have issues searching for users / groups in the AD (using your identify sources). This is how one of the ways to handle this issues and fix it.
Veeam Backup & Replication has added a new integration – Veeam Backup for Microsoft Office 365.  In this blog, we will discuss how you can benefit from Office 365 email backup with the Veeam’s new product and try to shed some light on the needs and …
Teach the user how to install and configure the vCenter Orchestrator virtual appliance Open vSphere Web Client: Deploy vCenter Orchestrator virtual appliance OVA file: Verify vCenter Orchestrator virtual appliance boots successfully: Connect to the …
This video shows you how easy it is to boot from ISO images for virtual machines with the ISO images stored on a local datastore on the ESXi host.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now