?
Solved

Windows Server 2008 - NTP Sending Wrong Time?

Posted on 2012-03-30
8
Medium Priority
?
784 Views
Last Modified: 2012-04-04
Hello,
I have a voicemail system that runs on a Linux backend that uses a local NTP server that is a windows 2008 server. Ever since the recent time change, all the voicmails have an incorrect timestamp.  

I've been troubleshooting the issue, and it seems like the problem on the server side not the VM switch.  I could be wrong though - the server itself shows the right time.  I've searched and installed the patches I can find from MS for daylight savings update.  The main thing I am seeing is that when I try to sync time, the switch shows an offset of an hour.  


[root@MSC-SG90V-1 ~]# ntpdate -d 172.30.43.8
30 Mar 07:36:27 ntpdate[29811]: ntpdate 4.2.4p3@1.1502 Wed Nov 28 04:08:22 UTC 2007 (1)
Looking for host 172.30.43.8 and service ntp
host found : ShoreTel.toaks.org
transmit(172.30.43.8)
receive(172.30.43.8)
transmit(172.30.43.8)
receive(172.30.43.8)
transmit(172.30.43.8)
receive(172.30.43.8)
transmit(172.30.43.8)
receive(172.30.43.8)
transmit(172.30.43.8)
server 172.30.43.8, port 123
stratum 1, precision -6, leap 00, trust 000
refid [LOCL], delay 0.04213, dispersion 0.00006
transmitted 4, in filter 4
reference time:    d3205125.9a3d70a3  Fri, Mar 30 2012  8:35:01.602
originate timestamp: d3205135.c3b645a1  Fri, Mar 30 2012  8:35:17.764
transmit timestamp:  d320436c.0612d773  Fri, Mar 30 2012  7:36:28.023
filter delay:  0.04234  0.04218  0.04213  0.04214
         0.00000  0.00000  0.00000  0.00000
filter offset: 3529.740 3529.740 3529.740 3529.740
         0.000000 0.000000 0.000000 0.000000
delay 0.04213, dispersion 0.00006
offset 3529.740370

30 Mar 07:36:28 ntpdate[29811]: step time server 172.30.43.8 offset 3529.740370 sec
0
Comment
Question by:JamesonJendreas
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
8 Comments
 
LVL 6

Expert Comment

by:Ramakrishna Prabhu
ID: 37787846
Could you please verify if your VM Switch and Server's are set to the same timezone?
0
 
LVL 1

Author Comment

by:JamesonJendreas
ID: 37787914
Yeah, same time zone - the way the VM switch works is that it's timezone is set by it's configuration server, and I can confirm that it is in the PT zone.  

It could be something on the switch itself, but the transmit time stamp is what's getting me. I'm wondering if someone did previously somehow hard-set this offset in the switch for a previous time change.
0
 
LVL 6

Expert Comment

by:Ramakrishna Prabhu
ID: 37787949
May be you could verify that, because the only reason i can thinking its having different time might be because of the timezone zone difference.

How ever i could be wrong!
0
WordPress Tutorial 2: Terminology

An important part of learning any new piece of software is understanding the terminology it uses. Thankfully WordPress uses fairly simple names for everything that make it easy to start using the software.

 
LVL 1

Author Comment

by:JamesonJendreas
ID: 37787961
OK - I think I can confirm that the problem is in the switch itself, so I may need to go to their tech support.  I noticed that the phones I have that are part of the same system - setup with the same timezone, are getting the correct time.  They were pointed to a different internal time server, and switching my VM switch over to that time server does the exact same things.
0
 
LVL 1

Author Comment

by:JamesonJendreas
ID: 37787991
So, I guess my next question would be does anyone know a BASH command for setting the offset for NTP?  I don't know if that exists or not...  Or, possibly I have to edit some config file on this unit.  Maybe that's what I need to attempt
0
 
LVL 1

Accepted Solution

by:
JamesonJendreas earned 0 total points
ID: 37788427
For the KB:


ln -sf ../usr/share/zoneinfo/US/Pacific /etc/localtime



Looks like there was a non-standard timezone selected
0
 
LVL 13

Expert Comment

by:Sandy
ID: 37793224
Is it a machine under openvz then you need to change it by using hyper-visor configuration.
0
 
LVL 1

Author Closing Comment

by:JamesonJendreas
ID: 37805159
Found the solution
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question