Backup failed

I have the maintenance plan  for the daily full backup and log backup . It has  failed for last two days. the error in the logs shows the following message

BackupDiskFile::CreateMedia: Backup device '\\mnsql01\sqlbackups\mnncdbprod01\full\rgsdyn_backup_2012_03_29_201531_3880704.bak' failed to create. Operating system error 86(The specified network password is not correct.).

I don;t know anything has changed (at least one body informed me). Can you suggest what should i do . How to fix the issue so that it won;t fail today?

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Casey HermanCitrix EngineerCommented:
Not sure what backup system you are using but it looks like the service account for that backup is either locked or the password has changed.

Last time I saw an error like that our NAS's computer account had to be re-added to AD because it wasn't authenticating properly.

You can try going to:

from the SQL server and see if you can access the folder.
manojbabaAuthor Commented:
Thanks Casey,

The account that runs the services is dedicated domain  service account . and when i  check the account properties it  is not locked. I am not sure whether someone changed the password or not but most probably not because it is used by all the services..

Suppose if the  password  were changed does it affect the backup process. ?
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

manojbabaAuthor Commented:
Thanks pclinuxguru,

I can access the folder from the sql server machine.but I am using my domain account to access the  \\mnsql01\sqlbackups\mnncdbprod01\full\ folder.

 And the other backup jobs  from different  sql server with different service account is also working  to the  same NAS  location , I don;t why it is failing.  

If we re add NAS's computer account had to AD  don;t it affect the other process currently running.

More than likely. If it works from other places then something else is wrong.

In SQL Studio do you have anything under backup Devices?
manojbabaAuthor Commented:
there is nothing under backup Devices.
Casey HermanCitrix EngineerCommented:
You will get a login error like above.  Depending on how locked down your service account is you can test it by creating a simple scheduled task to open notpad or something with the known password and see if the job runs. If it doesnt than the password has been changed.  Also you should check to see if password policies are allowed to affect that account.  If you are 100% sure what the password should be you can reset the password to the known password again and it should work.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
manojbabaAuthor Commented:
Thanks casedog21

Sorry, I was on vacation for few days . The jobs is still failing. I changed the owner of job to sql server agent account and  I also changed the ownersid  of sysssispackages as well in according to new account. this doesn't help.

Then I tried to create the new maintenance plan  with one backup job? but it also failed.

When i see the security of the NAS folder( \\mnsql01\sqlbackups\mnncdbprod01)  all the account i used has full control permission. I don;t know what wrong with this server.


I am going to check in reply soon and I will add that too soon.
manojbabaAuthor Commented:
I tried  with what you said it opens the notepad file.
manojbabaAuthor Commented:
The problem hasn't solved yet when  the check the permission on the shared folder in the NAS server. the service account used by sql server agent has full permission  and i run the job by same account.

I even tried to run the simple backup job from the query editor  using same and  different account separately having read/writhe permission on the  NAS folder and sysadmin right in the sql server gives the same error.

Cannot open backup device ''\\mnsql01\sqlbackups\mnncdbprod01\full'. Operating system error 1326(Logon failure: unknown user name or bad password.).
manojbabaAuthor Commented:
The problem is solved there the service account password was changed,
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.