SharePoint 2010 Word Document Problem

I am having a problem with a document library such that a word document which is uploaded upon clicking on it's hyperlink opens in word as READONLY.

The document us uploaded as READWRITE.  So,  it's not clear why this is occurring.

Please advise.
LVL 1
Howard BashSenior Software EngineerAsked:
Who is Participating?
 
macarrillo1Connect With a Mentor Commented:
Go to your document library.
Click 'Settings' and select 'Document Library Settings' from the drop down.
Under the 'General Settings', Click 'Versioning settings'.
Within 'Versioning Setting' ensure that both
'Content Approval' and 'Require Check Out' are set to No.
0
 
TempDBACommented:
There is some configuration, I am right now missing of. It will let you choose the option. Basically if you will checkout the document, it will be downloaded in editable format. Or else it will ask you for the option.
0
 
Howard BashSenior Software EngineerAuthor Commented:
Any idea where?  Is it in SharePoint or Word?  It does ask if you want to open it for read or edit and when I select edit it shows up READONLY.

I would imagine it's a SharePoint setting as this behavior happens regardless of which machine the document is launched from.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
macarrillo1Commented:
The setting is in SharePoint.  Like @TempDBA I don't remember where.  It would have to be in the Document Library settings.

However, it could be another issue.  What version of word are you using (ie 2007, 2010)?  I have experienced problems like this when saving or uploading documents that are a different version than SharePoint (ie SharePoint 2007 with Word 2003 or Word 2010).
0
 
Howard BashSenior Software EngineerAuthor Commented:
I am using SharePoint 2010 and Office 2010.   I did not see an entry in Document Library Settings for this issue as well.
0
 
Howard BashSenior Software EngineerAuthor Commented:
Unfortunately for me, both of those settings are already in place as you suggest and the problem persists.
0
 
macarrillo1Commented:
Within your 'Document Library Settings' under 'Permissions and Management' click
'Permissions for this document library'.  What are the permissions (ie. Read, Contribute, View only, etc) of the individual's group who is experiencing this problem?

Users will need a Contribute or better permission to be able to edit the document.
0
 
Howard BashSenior Software EngineerAuthor Commented:
I am an owner listed as having full control and I get this behavior.
0
 
macarrillo1Commented:
If you have access to SharePoint Central;
Go to the 'Application Management' tab.
Under the 'Application Security' heading click 'User permissions for Web application'
Verify that all permissions are enabled.  Especially under 'List Permissions' heading your 'Edit Items' should be enabled.

If you do not have access to SharePoint Central, then ask your SharePoint Administrator to check these setting for you.
0
 
macarrillo1Commented:
You might also look at these resources to see if it applies to you:

Microsoft support

and also this previous Expert Exchange question.  Their solution is at the bottom.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.