[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 530
  • Last Modified:

Windows 2003 Terminal Server can't keep Licensing Server on Windows 2008 Server.

Hi,
 
 I have a windows 2008 Server running Terminal service (PC Name: TS1) and also runs licensing server. TS1 is NOT a domain controller and I have a SBS2011 as DC.
The problem is my windows 2003 Terminal server (PC Name: TS2) can't keep licensing server information.
Here is what happens. I open Terminla Server Licensing program on TS2 and enter TS1 as Terminal Licensing server. It shows TS1 as activated. But the moment that I close Terminla Server Licensing program and reopen, it says "no Terminla server license server is available...". Please see attached.

 Does anyone have some experience with this issue?

PS. I spoke to Microsoft about this and they said that Terminal licensing server does not have to be installed on the domain controller.

 Thanks.
TS-Licensing.docx
0
sglee
Asked:
sglee
  • 3
  • 2
1 Solution
 
Dirk KotteSECommented:
ok, the MMC can't find the TS-LS. thats should not be a problem. i is only an management-application.
if the "auto discover" features not availeble, you have to set the pointer to your license-server manually.
within the TS goto TS-/RDS- konfiguration and switch from auto to "this license-servers".

At this config-screen you also have to configure the licensing-type (user or device) matching to your installed TS-licenses.
0
 
sgleeAuthor Commented:
Would you mind giving exact steps to set the discovery mode in TS2?
0
 
Dirk KotteSECommented:
goto Terminalservicesconfiguration / Serversettings / LS Serch-mode (see attachment1)
doubleclick LS-serch-mode = Auto and set your LS-Server (see attachment 2)

thats all
licensing1.JPG
licensing2.JPG
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
robdlCommented:
Set it in the registry of the 2003 machine.

1. Click Start, click Run, type regedit, and then click OK.


2. Locate, and then click, the following key in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters


3. On the Edit menu, point to New, click Key, and then type LicenseServers to name the new key.


4. Locate, and then click, the following key in the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters\LicenseServers


5. On the Edit menu, point to New, click Key, and then type ServerName where ServerName is the NetBIOS name of the license server that you want to use, and then press ENTER.

The new key name can be any of the following designations that represent the license server:

The NetBIOS name of the server
The fully-qualified domain name (FQDN) of the server
The IP address of the server


Restart your computer
0
 
sgleeAuthor Commented:
robdl,
I have a question. What is the difference between your suggestion and dkotte's suggestion?
It looks to me that if both method is going to solve the problem, then dkotte's suggestion looks simpler.
0
 
Dirk KotteSECommented:
at the given path within the registry the GUI from my post stores the settings.
;-)
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now